summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Brummer2017-10-24 17:00:57 +0200
committerBenoit Brummer2017-10-24 17:00:57 +0200
commitc570dbebfec002f2fa76b3d8ab32023926cda70e (patch)
tree70881f5f1669d94262a434bd63557023b0de81a5
downloadaur-c570dbebfec002f2fa76b3d8ab32023926cda70e.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd14f5e7c7f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-hmms
+ pkgdesc = Discrete-time and continuous-time hidden Markov model library
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/hmms
+ arch = any
+ license = Public Domain
+ depends = python
+ depends = cython
+ depends = ipython
+ depends = python-matplotlib
+ depends = jupyter-notebook
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-scipy
+ source = https://files.pythonhosted.org/packages/source/h/hmms/hmms-0.1.tar.gz
+ md5sums = 0d586c8d120355328e5a96ba4da9c950
+
+pkgname = python-hmms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e332f67a2ed0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname='python-hmms'
+_name='hmms'
+pkgver=0.1
+pkgrel=1
+pkgdesc='Discrete-time and continuous-time hidden Markov model library'
+url='https://pypi.python.org/pypi/hmms'
+depends=('python' 'cython' 'ipython' 'python-matplotlib' 'jupyter-notebook' 'python-numpy' 'python-pandas' 'python-scipy')
+license=('Public Domain')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('0d586c8d120355328e5a96ba4da9c950')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ sed -i 's/include_dirs/include_path/' setup.py
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+