summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxr19982019-02-11 12:50:06 +0100
committerMaxr19982019-02-11 12:50:06 +0100
commitdaa17f43cc1a976f3fd5d2d051a168c4653e2395 (patch)
tree8391f449d1cc8745fd63a88ff547d45e2a386f84
parent55cb3d64c35ee382fc1499038038f32f434dc6ec (diff)
downloadaur-daa17f43cc1a976f3fd5d2d051a168c4653e2395.tar.gz
Update to 0.5.0
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44e9227cd35d..b2f4b295139d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
_name=homeassistant-cli
pkgname=python-homeassistant-cli
-pkgver=0.4.4
+pkgver=0.5.0
pkgrel=1
pkgdesc='Command-line tool for Home Assistant'
arch=('any')
url=https://github.com/home-assistant/home-assistant-cli
license=('Apache')
-depends=('python' 'python-requests' 'python-yaml' 'python-netdisco' 'python-click' 'python-click-log' 'python-tabulate' 'python-jsonpath-rw' 'python-jinja' 'python-dateparser' 'python-setuptools')
+depends=('python' 'python-requests' 'python-netdisco' 'python-click' 'python-click-log' 'python-tabulate' 'python-jsonpath-rw' 'python-jinja' 'python-dateparser' 'python-regex' 'python-ruamel-yaml' 'python-aiohttp' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/h/homeassistant-cli/$_name-$pkgver.tar.gz")
-sha512sums=("b8a9d8ea6f70dbe2a39e27d3284dc6ededb6e3be44f7de66c52ebe1195c95fda175b80df39223d0313462d31969bf7fc22cd159381fb524b2c3d8e3705b7f072")
+sha512sums=("9d07d0e3a7a0fae9d5d7431b18207c2ec6615bf03c6b8c8a600a0d07618ae55cebbbd49456fe702a1300a8327f0a02ee57b528fab60ec4a997f2fb5feb755526")
build() {
cd $_name-$pkgver
- echo "Patching pyyaml to use 3.13 stable instead of 4.2b1…"
- sed -i 's/pyyaml>=4.2b1/pyyaml>=3.13/' setup.py
+ sed -i 's/regex==2019.01.24/regex==2019.02.06/' setup.py
+ sed -i 's/ruamel.yaml==0.15.85/ruamel.yaml==0.15.87/' setup.py
python setup.py build
}