summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2024-03-04 20:20:25 +0800
committerlilac2024-03-04 20:20:25 +0800
commit0d63d83d43f4478219b87d1ef504d9087f5e79f2 (patch)
treeae111c6b017154c06309151794622bf57bad9d52
parentf9ca0d3a13b4d1ffc1d0a2166b1d74745037137b (diff)
downloadaur-python-horovod.tar.gz
[lilac] updated to 0.28.1-3
-rw-r--r--.SRCINFO12
-rw-r--r--0002-fix-building-torch-extension-with-glog.patch24
-rw-r--r--PKGBUILD16
3 files changed, 42 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e6b566d9136..42dab2a8f8d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-horovod
pkgdesc = Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet
pkgver = 0.28.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/horovod/horovod
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = cmake
makedepends = git
makedepends = python-build
@@ -15,6 +15,8 @@ pkgbase = python-horovod
makedepends = python-wheel
depends = cuda
depends = cudnn
+ depends = gcc-libs
+ depends = glibc
depends = nccl
depends = openmpi
depends = python-cloudpickle
@@ -30,8 +32,10 @@ pkgbase = python-horovod
optdepends = python-pytorch-cuda: pytorch framework
optdepends = python-tensorflow-cuda: tensorflow framework
source = horovod-0.28.1::git+https://github.com/horovod/horovod.git#tag=v0.28.1
- source = 0001.fix-building-with-torch-2.1.patch::https://github.com/horovod/horovod/pull/3998.patch
+ source = 0001-fix-building-with-torch-2.1.patch::https://github.com/horovod/horovod/pull/3998.patch
+ source = 0002-fix-building-torch-extension-with-glog.patch
sha512sums = SKIP
- sha512sums = 32ec82943a5f96de21b11b2b994f30779d827d8a5dab380654169eebc954e0dc122333d610fc32607a8bf11dd425117d035ab1f1cb8c6a36717c3c0b89692431
+ sha512sums = 7c56b56e665e0590ced4366d71dcd5ed83cab7e2943b0548d0472ef19b5a051a9dcaa8800c417882b171acbe4dc5f745e1c876aabb0bb8564215ce121f14cf67
+ sha512sums = 52850f5e4f60122e0064307f0d5d5fb6781c8f77f0e54d4b9c306e98bd15d1edc1c670a1623653fb571332c74cb11d7ffd5a1b7e6fe3403f990cc96ca5ccf7c0
pkgname = python-horovod
diff --git a/0002-fix-building-torch-extension-with-glog.patch b/0002-fix-building-torch-extension-with-glog.patch
new file mode 100644
index 000000000000..a06512fde528
--- /dev/null
+++ b/0002-fix-building-torch-extension-with-glog.patch
@@ -0,0 +1,24 @@
+From b4a923c3017d77c45124a2209e6e8d64a926ad43 Mon Sep 17 00:00:00 2001
+From: Hu Butui <hot123tea123@gmail.com>
+Date: Mon, 4 Mar 2024 14:26:28 +0800
+Subject: [PATCH] fix building torch extension with glog
+
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2c127190..7666647b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,6 +74,7 @@ list(APPEND SOURCES "${PROJECT_SOURCE_DIR}/horovod/common/common.cc"
+
+ # Default Macro
+ add_definitions(-DEIGEN_MPL2_ONLY=1)
++add_definitions(-DGLOG_USE_GLOG_EXPORT)
+
+ # Remove platform default std
+ string(REGEX REPLACE "-std=[^ ]+" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+--
+2.43.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 53e00e058b6b..48bad7df6863 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,16 @@
_pkgname=horovod
pkgname=python-horovod
pkgver=0.28.1
-pkgrel=2
+pkgrel=3
pkgdesc='Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet'
arch=('x86_64')
url='https://github.com/horovod/horovod'
-license=('Apache')
+license=('Apache-2.0')
depends=(
cuda
cudnn
+ gcc-libs
+ glibc
nccl
openmpi
python-cloudpickle
@@ -39,14 +41,17 @@ optdepends=(
'python-tensorflow-cuda: tensorflow framework'
)
source=("${_pkgname}-${pkgver}::git+https://github.com/horovod/horovod.git#tag=v${pkgver}"
- "0001.fix-building-with-torch-2.1.patch::https://github.com/horovod/horovod/pull/3998.patch"
+ "0001-fix-building-with-torch-2.1.patch::https://github.com/horovod/horovod/pull/3998.patch"
+ "0002-fix-building-torch-extension-with-glog.patch"
)
sha512sums=('SKIP'
- '32ec82943a5f96de21b11b2b994f30779d827d8a5dab380654169eebc954e0dc122333d610fc32607a8bf11dd425117d035ab1f1cb8c6a36717c3c0b89692431')
+ '7c56b56e665e0590ced4366d71dcd5ed83cab7e2943b0548d0472ef19b5a051a9dcaa8800c417882b171acbe4dc5f745e1c876aabb0bb8564215ce121f14cf67'
+ '52850f5e4f60122e0064307f0d5d5fb6781c8f77f0e54d4b9c306e98bd15d1edc1c670a1623653fb571332c74cb11d7ffd5a1b7e6fe3403f990cc96ca5ccf7c0')
prepare() {
cd "${_pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/0001.fix-building-with-torch-2.1.patch"
+ patch -p1 -i "${srcdir}/0001-fix-building-with-torch-2.1.patch"
+ patch -p1 -i "${srcdir}/0002-fix-building-torch-extension-with-glog.patch"
git submodule update --init --recursive
}
@@ -75,4 +80,3 @@ package() {
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et:
-