summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-10-08 12:33:09 +0800
committerlilac2021-10-08 12:33:09 +0800
commit65c9f59a1811bf513a4f7c34f92c5f105a11d559 (patch)
tree3c29db4340011374511bdfc3d495bb6cfa8887f8
parent1993a5e30461f93dcc1492dcb4e26d9eaff8a3fa (diff)
downloadaur-65c9f59a1811bf513a4f7c34f92c5f105a11d559.tar.gz
[lilac] updated to 0.23.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae1ca9f409c6..f23fb37bb4b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = python-horovod
pkgdesc = Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet
- pkgver = 0.21.3
+ pkgver = 0.23.0
pkgrel = 1
url = https://github.com/horovod/horovod
arch = x86_64
license = Apache
makedepends = cmake
makedepends = git
- makedepends = mxnet-cuda
makedepends = python-pip
makedepends = python-pytorch-cuda
makedepends = python-setuptools
@@ -26,11 +25,9 @@ pkgbase = python-horovod
depends = python-scipy
depends = python-six
depends = python-tqdm
- optdepends = mxnet-cuda: mxnet framework
optdepends = python-pytorch-cuda: pytorch framework
optdepends = python-tensorflow-cuda: tensorflow framework
- source = horovod-0.21.3::git+https://github.com/horovod/horovod.git#tag=v0.21.3
+ source = horovod-0.23.0::git+https://github.com/horovod/horovod.git#tag=v0.23.0
sha512sums = SKIP
pkgname = python-horovod
-
diff --git a/PKGBUILD b/PKGBUILD
index cc79a41bd6f5..e732b425f331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=horovod
pkgname=python-horovod
-pkgver=0.21.3
+pkgver=0.23.0
pkgrel=1
pkgdesc='Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet'
arch=('x86_64')
@@ -27,14 +27,12 @@ depends=(
makedepends=(
cmake
git
- mxnet-cuda
python-pip
python-pytorch-cuda
python-setuptools
python-tensorflow-cuda
)
optdepends=(
- 'mxnet-cuda: mxnet framework'
'python-pytorch-cuda: pytorch framework'
'python-tensorflow-cuda: tensorflow framework'
)
@@ -56,10 +54,10 @@ prepare() {
export HOROVOD_GPU_BROADCAST=NCCL
export HOROVOD_WITH_GLOO=1
export HOROVOD_WITH_MPI=1
- export HOROVOD_WITH_MXNET=1
+ export HOROVOD_WITH_MXNET=0
export HOROVOD_WITH_PYTORCH=1
export HOROVOD_WITH_TENSORFLOW=1
- export HOROVOD_BUILD_CUDA_CC_LIST="52,53,60,61,62,70,72,75,80"
+ export HOROVOD_BUILD_CUDA_CC_LIST="52,53,60,61,62,70,72,75,80,86"
export CC=/opt/cuda/bin/gcc
export CXX=/opt/cuda/bin/g++
export MAKEFLAGS="-j1"