summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-04-18 18:45:28 +0800
committerlilac2020-04-18 18:45:28 +0800
commit84140f1cf2373e62bc0330b82058e56ec57dd8ab (patch)
tree4571a641428084ba6c7930ec81f047ce9dbebf82
parentce99136049905a4f5305d5b1cc6ee382aa8ef4f5 (diff)
downloadaur-84140f1cf2373e62bc0330b82058e56ec57dd8ab.tar.gz
update by lilac
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2992ba33ba2..0d8530149102 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-horovod
pkgdesc = Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet
pkgver = 0.19.1
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/horovod/horovod
arch = x86_64
license = Apache
makedepends = cmake
makedepends = git
makedepends = mxnet-cuda
- makedepends = python-keras-applications
makedepends = python-pytorch-cuda
makedepends = python-setuptools
makedepends = python-tensorflow-cuda
@@ -16,13 +15,17 @@ pkgbase = python-horovod
depends = cudnn
depends = nccl
depends = openmpi
+ depends = python-cloudpickle
depends = python-h5py
depends = python-mock
depends = python-mpi4py
+ depends = python-psutil
+ depends = python-pycparser
+ depends = python-pyaml
depends = python-scipy
+ depends = python-six
depends = python-tqdm
optdepends = mxnet-cuda
- optdepends = python-keras-applications
optdepends = python-pytorch-cuda
optdepends = python-tensorflow-cuda
source = horovod-0.19.1::git+https://github.com/horovod/horovod.git#tag=v0.19.1
diff --git a/PKGBUILD b/PKGBUILD
index d2d2ebb479af..58d46287f1ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=horovod
pkgname=python-horovod
pkgver=0.19.1
-pkgrel=1
+pkgrel=3
pkgdesc='Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet'
arch=('x86_64')
url='https://github.com/horovod/horovod'
@@ -13,24 +13,27 @@ depends=(
'cudnn'
'nccl'
'openmpi'
+ 'python-cloudpickle'
'python-h5py'
'python-mock'
'python-mpi4py'
+ 'python-psutil'
+ 'python-pycparser'
+ 'python-pyaml'
'python-scipy'
+ 'python-six'
'python-tqdm'
)
makedepends=(
'cmake'
'git'
'mxnet-cuda'
- 'python-keras-applications'
'python-pytorch-cuda'
'python-setuptools'
'python-tensorflow-cuda'
)
optdepends=(
'mxnet-cuda'
- 'python-keras-applications'
'python-pytorch-cuda'
'python-tensorflow-cuda'
)