summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Klinkovský2019-12-23 14:25:09 +0100
committerJakub Klinkovský2019-12-23 14:25:09 +0100
commit67087522e3f9fb16061aaf59bfed02a75efbb18e (patch)
treebe9e0662fa27095834bbe46ee21b8603f84a18b1
downloadaur-67087522e3f9fb16061aaf59bfed02a75efbb18e.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ac0b38482d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Dec 23 13:25:02 UTC 2019
+pkgbase = python-hostlist
+ pkgdesc = Python module for hostlist handling
+ pkgver = 1.18
+ pkgrel = 1
+ url = https://www.nsc.liu.se/~kent/python-hostlist/
+ arch = x86_64
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ source = https://www.nsc.liu.se/~kent/python-hostlist/python-hostlist-1.18.tar.gz
+ md5sums = a910435cd2a0c026d55c5999f1ca5197
+
+pkgname = python-hostlist
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6b5e5e85edd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.pkg.tar.xz
+*.pkg.tar.xz.sig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4730a5aee4d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jakub Klinkovský <j.l.k@gmx.com>
+
+pkgname=python-hostlist
+pkgdesc="Python module for hostlist handling"
+pkgver=1.18
+pkgrel=1
+arch=('x86_64')
+url="https://www.nsc.liu.se/~kent/python-hostlist/"
+license=('GPL2')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://www.nsc.liu.se/~kent/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('a910435cd2a0c026d55c5999f1ca5197')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: