summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadim Sückr2020-01-13 00:12:38 +0100
committerRadim Sückr2020-01-13 00:12:38 +0100
commitc954328901d58e5436bf8caf737785ec3e8d74be (patch)
tree496b03d5c79a41aa55fa78e3f16638abe43ba8ec
downloadaur-c954328901d58e5436bf8caf737785ec3e8d74be.tar.gz
First release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63d2df239ee0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-hosts
+ pkgdesc = A hosts file manager library written in python
+ pkgver = 0.4.7
+ pkgrel = 1
+ url = https://github.com/jonhadfield/python-hosts
+ arch = any
+ license = MIT
+ source = git+https://github.com/jonhadfield/python-hosts.git
+ sha512sums = SKIP
+
+pkgname = python-hosts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83251c76938d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Radim Sückr <contact@radimsuckr.cz>
+
+pkgname=python-hosts
+pkgver=0.4.7
+pkgrel=1
+pkgdesc='A hosts file manager library written in python'
+arch=('any')
+url='https://github.com/jonhadfield/python-hosts'
+license=('MIT')
+source=('git+https://github.com/jonhadfield/python-hosts.git')
+sha512sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+}