summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBijaya Dangol2016-10-25 17:19:57 +0545
committerBijaya Dangol2016-10-25 17:19:57 +0545
commit5deebd3e1677e95f23e0d6bd261505c936e9954d (patch)
tree9b220e2490d1cc55f471a26b0c69aadaa7986dad
downloadaur-5deebd3e1677e95f23e0d6bd261505c936e9954d.tar.gz
start python hsaudiotag3k
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02a9c469f7d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-hsaudiotag3k
+ pkgdesc = Read metadata (tags) of mp3, mp4, wma, ogg, flac and aiff files (python3 version)
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/hsaudiotag3k
+ arch = any
+ license = BSD
+ makedepends = python-distribute
+ depends = python
+ source = http://pypi.python.org/packages/source/h/hsaudiotag3k/hsaudiotag3k-1.1.3.tar.gz
+ md5sums = 77fc873857303e889851605e9836669b
+
+pkgname = python-hsaudiotag3k
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9aabda1193c2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar
+*.pkg.tar.*
+pkg/
+src/
+hsaudiotag3k-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..865377630b44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# vim:set ts=2 sw=2 et:
+# Maintainer: Bijaya Dangol <dangoldbj23@gmail.com>
+
+pkgname=python-hsaudiotag3k
+_reponame=hsaudiotag3k
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="Read metadata (tags) of mp3, mp4, wma, ogg, flac and aiff files (python3 version)"
+url="http://pypi.python.org/pypi/hsaudiotag3k"
+arch=(any)
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+source=("http://pypi.python.org/packages/source/h/${_reponame}/${_reponame}-$pkgver.tar.gz")
+md5sums=('77fc873857303e889851605e9836669b')
+
+build() {
+ cd "$srcdir/${_reponame}-$pkgver"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/${_reponame}-$pkgver"
+ python3 setup.py install --root="$pkgdir"
+}