summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMidov2020-03-29 14:04:48 +0200
committerMidov2020-03-29 14:04:48 +0200
commiteecb86525a26b161afab2c1153a8be3c8e92bdf2 (patch)
treed62da47545124ad6b9aa83f199c7d27d1db892d7
downloadaur-eecb86525a26b161afab2c1153a8be3c8e92bdf2.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..377b652a096a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-html-sanitizer
+ pkgdesc = Allowlist-based and very opinionated HTML sanitizer that can be used both for untrusted and trusted sources.
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = https://pypi.org/project/filetype/
+ arch = any
+ license = GPL
+ depends = python
+ source = https://files.pythonhosted.org/packages/72/ff/88fbb7c46d359f7cbf1f8bc9f63379ed6b5e3940a9fda88f9cf5cedf24da/html-sanitizer-1.9.0.tar.gz
+ sha256sums = ef86b10c653b288dff4c51c0cc9cf93025c4c6a519a6e40eb1aa152861101929
+
+pkgname = python-html-sanitizer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33775eb4e230
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Midov <midov@midov.pl>
+
+pkgname=python-html-sanitizer
+_name=html-sanitizer
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="Allowlist-based and very opinionated HTML sanitizer that can be used both for untrusted and trusted sources."
+arch=('any')
+url="https://pypi.org/project/filetype/"
+license=('GPL')
+depends=('python')
+source=("https://files.pythonhosted.org/packages/72/ff/88fbb7c46d359f7cbf1f8bc9f63379ed6b5e3940a9fda88f9cf5cedf24da/${_name}-${pkgver}.tar.gz")
+sha256sums=('ef86b10c653b288dff4c51c0cc9cf93025c4c6a519a6e40eb1aa152861101929')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}