summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-01-31 13:40:31 +0300
committerCaleb Maclennan2022-01-31 13:40:31 +0300
commit110467fd42302cf8875021b1d8e5f38878786d15 (patch)
treebf7900ae50e8da37c914f1d31e1031daeb3e6c5e
parent438fd702aca321431f8c7e60a98fed826d1b9f3d (diff)
downloadaur-110467fd42302cf8875021b1d8e5f38878786d15.tar.gz
upgpkg: python-htmllistparse 0.6.0-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD43
2 files changed, 27 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caf8efe5ea35..3d78a37ba92a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-htmllistparse
pkgdesc = Python parser for Apache/nginx-style HTML directory listing
- pkgver = 0.5.2
- pkgrel = 2
+ pkgver = 0.6.0
+ pkgrel = 1
url = https://github.com/gumblex/htmllisting-parser
arch = any
license = MIT
@@ -10,8 +10,7 @@ pkgbase = python-htmllistparse
depends = python-html5lib
depends = python-requests
depends = python-fusepy
- source = htmllistparse-0.5.2.zip::https://github.com/gumblex/htmllisting-parser/archive/4e70b5ab7be69e33fc0b5d0bf14bfc67f3611780.zip
- b2sums = db0ce06f73da9d0bad01807b39180417402863e21054da50cf9d0373494e82d54f0000a746011c0695a7c46114867e177c39b50e1284925c97be20224439aeef
+ source = https://files.pythonhosted.org/packages/source/h/htmllistparse/htmllistparse-0.6.0.tar.gz
+ sha256sums = 9ac274a165a02bf503656df4b48e1ae9eec0df40723a5f998f9023d3df3c8e32
pkgname = python-htmllistparse
-
diff --git a/PKGBUILD b/PKGBUILD
index e9f2bef335c1..17cbf14cd7ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
-# Maintainer: RubenKelevra
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: RubenKelevra
-_pkgname=htmllistparse
+_pyname=htmllistparse
pkgname=python-htmllistparse
-pkgver=0.5.2
-pkgrel=2
-pkgdesc="Python parser for Apache/nginx-style HTML directory listing"
-url="https://github.com/gumblex/htmllisting-parser"
-depends=('python'
- 'python-beautifulsoup4'
- 'python-html5lib'
- 'python-requests'
- 'python-fusepy')
-license=('MIT')
-arch=('any')
-source=('htmllistparse-0.5.2.zip::https://github.com/gumblex/htmllisting-parser/archive/4e70b5ab7be69e33fc0b5d0bf14bfc67f3611780.zip')
-b2sums=('db0ce06f73da9d0bad01807b39180417402863e21054da50cf9d0373494e82d54f0000a746011c0695a7c46114867e177c39b50e1284925c97be20224439aeef')
+pkgver=0.6.0
+pkgrel=1
+pkgdesc='Python parser for Apache/nginx-style HTML directory listing'
+url=https://github.com/gumblex/htmllisting-parser
+license=(MIT)
+arch=(any)
+_pydeps=(beautifulsoup4
+ html5lib
+ requests
+ fusepy)
+depends=(python
+ "${_pydeps[@]/#/python-}")
+_archive="$_pyname-$pkgver"
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
+sha256sums=('9ac274a165a02bf503656df4b48e1ae9eec0df40723a5f998f9023d3df3c8e32')
build() {
- mv $srcdir/htmllisting-parser-4e70b5ab7be69e33fc0b5d0bf14bfc67f3611780 $srcdir/${_pkgname}-${pkgver}
- cd $srcdir/${_pkgname}-${pkgver}
- python setup.py build
+ cd "$_archive"
+ python setup.py build
}
package() {
- cd $srcdir/${_pkgname}-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}