summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-11-01 16:09:48 +0100
committerGrey Christoforo2020-11-01 16:09:48 +0100
commit6a7b4715de64712bb86446b960794b81bfee987b (patch)
treeb2ca28e6f5a88ffc51662846c2a3c32732c5651a
parent5534b325bb65a4a1a0eb122a2283694a2e772f0f (diff)
downloadaur-python-htseq.tar.gz
bump version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71d509f759cb..d8229d8ba76a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-htseq
pkgdesc = library to facilitate processing and analysis of data from high-throughput sequencing (HTS) experiments
- pkgver = 0.11.2
+ pkgver = 0.11.3
pkgrel = 1
url = https://github.com/simon-anders/htseq
- arch = any
- license = GPL-3.0
+ arch = x86_64
+ license = GPL3
makedepends = python-setuptools
makedepends = cython
makedepends = swig
@@ -12,8 +12,8 @@ pkgbase = python-htseq
depends = python-matplotlib
depends = python-numpy
depends = python-pysam
- source = https://github.com/simon-anders/htseq/archive/release_0.11.2.tar.gz
- sha256sums = dfc707effa699d5ba9034e1bb9f13c0fb4e9bc60d31ede2444aa49c7e2fc71aa
+ source = https://github.com/simon-anders/htseq/archive/release_0.11.3.tar.gz
+ sha256sums = e9a8557fc350840ed7e6ed843e795de8a58b1dc09e18b3933e7484e219e6dcaf
pkgname = python-htseq
diff --git a/PKGBUILD b/PKGBUILD
index d4d145e7f06f..27104a897cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
-_module_name=htseq
-pkgname=python-${_module_name}
-pkgver=0.11.2
+pkgname=python-htseq
+pkgver=0.11.3
pkgrel=1
pkgdesc="library to facilitate processing and analysis of data from high-throughput sequencing (HTS) experiments"
-arch=('any')
+arch=(x86_64)
url=https://github.com/simon-anders/htseq
-license=('GPL-3.0')
+license=(GPL3)
depends=(python python-matplotlib python-numpy python-pysam)
makedepends=(python-setuptools cython swig)
-source=("https://github.com/simon-anders/${_module_name}/archive/release_${pkgver}.tar.gz")
-sha256sums=('dfc707effa699d5ba9034e1bb9f13c0fb4e9bc60d31ede2444aa49c7e2fc71aa')
+source=("https://github.com/simon-anders/htseq/archive/release_${pkgver}.tar.gz")
+sha256sums=('e9a8557fc350840ed7e6ed843e795de8a58b1dc09e18b3933e7484e219e6dcaf')
build() {
- cd "$srcdir/${_module_name}-release_$pkgver"
+ cd htseq-release_$pkgver
python setup.py build
}
-
package(){
- cd "$srcdir/${_module_name}-release_$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd htseq-release_$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:ts=2:sw=2:et: