summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTioDuke2018-06-06 22:35:40 -0400
committerTioDuke2018-06-06 22:35:40 -0400
commit1f70db6340e3b0623178af4d6d70b0b483d0b3b6 (patch)
tree0330be4efb320b75c7c61ceaef6d8ee915be85b7
downloadaur-1f70db6340e3b0623178af4d6d70b0b483d0b3b6.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3afb6fb4534
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-http-ece
+ pkgdesc = Encrypted Content Encoding for HTTP
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://pypi.org/project/http-ece
+ arch = any
+ license = MIT
+ depends = python
+ source = https://files.pythonhosted.org/packages/5c/20/aea4ced375989e35de1e420193c7d5af621d77b6fe4a827d936e67f5a2ea/http_ece-1.0.5.tar.gz
+ sha256sums = 2f31a0640c31a0c2934ab1e37005dd9a559ae854a16304f9b839e062074106cc
+
+pkgname = python-http-ece
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71726569ce92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Sergio Tridente < tioduke (at) gmail (dot) com >
+
+pkgname=python-http-ece
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Encrypted Content Encoding for HTTP"
+arch=('any')
+url="https://pypi.org/project/http-ece"
+license=('MIT')
+depends=(python)
+source=(https://files.pythonhosted.org/packages/5c/20/aea4ced375989e35de1e420193c7d5af621d77b6fe4a827d936e67f5a2ea/http_ece-${pkgver}.tar.gz)
+sha256sums=('2f31a0640c31a0c2934ab1e37005dd9a559ae854a16304f9b839e062074106cc')
+
+package() {
+ cd "http_ece-$pkgver"
+
+ python ./setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}