summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-12-27 19:54:09 +0800
committertaotieren2024-12-27 19:54:09 +0800
commit67ee9fb35b2a35a4793a5154c0161e339b676421 (patch)
tree89d423faa61fea73617d723d8b82da1fd2ffb9ab
downloadaur-67ee9fb35b2a35a4793a5154c0161e339b676421.tar.gz
update python-http-request
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1acec984f589
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-http-request
+ pkgdesc = Python http response utils.
+ pkgver = 0.0.5.3
+ pkgrel = 1
+ url = https://pypi.org/project/python-http-request
+ arch = any
+ license = MIT
+ makedepends = python-poetry
+ makedepends = python-poetry-core
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python
+ depends = python-asynctools
+ depends = python-filewrap
+ depends = python-integer-tool
+ depends = python-texttools
+ provides = python-http-request
+ conflicts = python-http-request
+ options = !strip
+ options = !debug
+ source = python_http_request-0.0.5.3.tar.gz::https://files.pythonhosted.org/packages/source/p/python_http_request/python_http_request-0.0.5.3.tar.gz
+ sha256sums = 7ca5a606e0198949413315df0654b2d50185e47bd3841f9197e2a94f7dae83f5
+
+pkgname = python-http-request
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22aaf6ac381e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=python-http-request
+_name=${pkgname//-/_}
+pkgver=0.0.5.3
+pkgrel=1
+epoch=
+pkgdesc="Python http response utils."
+arch=('any')
+url="https://pypi.org/project/${pkgname}"
+license=(MIT)
+groups=()
+provides=(${pkgname})
+conflicts=(${pkgname})
+depends=(
+ python
+ #AUR
+ python-asynctools
+ python-filewrap
+ python-integer-tool
+ python-texttools
+)
+makedepends=(
+ python-poetry
+ python-poetry-core
+ python-build
+ python-installer
+ python-wheel
+ python-setuptools)
+options=('!strip' '!debug')
+source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+noextract=()
+sha256sums=('7ca5a606e0198949413315df0654b2d50185e47bd3841f9197e2a94f7dae83f5')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}