summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreschwartz2020-09-22 04:13:22 +0000
committerJakob Gahde2022-01-05 11:46:18 +0100
commit7fa0e113881f047b39179693c802a300c5e2a34b (patch)
tree3d0d6cd4bf8f77c8b139bc9c07b53a086f0562e7
parent92159eda37fc93b7a5f5fc436d0aec68dfdce1d8 (diff)
downloadaur-7fa0e113881f047b39179693c802a300c5e2a34b.tar.gz
upgpkg: python-httpcore 0.10.2-1: upstream release
http2 is now an optional extra, plus new checkdepends git-svn-id: file:///srv/repos/svn-community/svn@711334 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 987ca65b275e..325626a4c0ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = python-httpcore
pkgdesc = A minimal HTTP client
- pkgver = 0.9.1
- pkgrel = 3
+ pkgver = 0.10.2
+ pkgrel = 1
url = https://github.com/encode/httpcore
arch = any
license = BSD
checkdepends = python-pytest-asyncio
checkdepends = python-pytest-trio
checkdepends = python-trustme
+ checkdepends = uvicorn
checkdepends = mitmproxy
makedepends = python-setuptools
+ makedepends = python-h2
depends = python-h11
- depends = python-h2
depends = python-sniffio
- source = python-httpcore-0.9.1.tar.gz::https://github.com/encode/httpcore/archive/0.9.1.tar.gz
- sha512sums = 5105ff0c19b8a4a34080e79aa1d191199131450e658fbe0949b091e5acfb9cd8b11033757a3bd7dd1490e5fb61352eb44d086babd70d22be33479befd16745fd
- b2sums = 8f7416c1e726892b152e7e9623790ac1e70b9142f45028b23df25f1d54b6f113f1a79839ec2a7d90b196197d53c880847526c2e47e07d52a0e104a9e2849bccf
+ optdepends = python-h2: for HTTP/2 support
+ source = python-httpcore-0.10.2.tar.gz::https://github.com/encode/httpcore/archive/0.10.2.tar.gz
+ sha512sums = 714ae548d194f5eb71447d13669b32ae9b37deee5791e0e171e04c721eb99f21c55996cc06cf82f115d9e11d806c1d6c0b54fe61922bb419d90c94cd93e374ce
+ b2sums = ad5615b6a45dc5cd1a0128a6a6a48b0b29a4f56b753869c55018913a9047d712a028ed74a8fa2fcee36cc851f1c0f85a9f4ddf7c7aa1f5e3b28b09761c511aea
pkgname = python-httpcore
diff --git a/PKGBUILD b/PKGBUILD
index a807db5a008b..1364626b76a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
_pkgname=httpcore
pkgname=python-httpcore
-pkgver=0.9.1
-pkgrel=3
+pkgver=0.10.2
+pkgrel=1
pkgdesc="A minimal HTTP client"
arch=('any')
url="https://github.com/encode/${_pkgname}"
license=('BSD')
-depends=('python-h11' 'python-h2' 'python-sniffio')
-makedepends=('python-setuptools')
-checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-trustme' 'mitmproxy')
+depends=('python-h11' 'python-sniffio')
+optdepends=('python-h2: for HTTP/2 support')
+makedepends=('python-setuptools' 'python-h2')
+checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-trustme' 'uvicorn' 'mitmproxy')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha512sums=('5105ff0c19b8a4a34080e79aa1d191199131450e658fbe0949b091e5acfb9cd8b11033757a3bd7dd1490e5fb61352eb44d086babd70d22be33479befd16745fd')
-b2sums=('8f7416c1e726892b152e7e9623790ac1e70b9142f45028b23df25f1d54b6f113f1a79839ec2a7d90b196197d53c880847526c2e47e07d52a0e104a9e2849bccf')
+sha512sums=('714ae548d194f5eb71447d13669b32ae9b37deee5791e0e171e04c721eb99f21c55996cc06cf82f115d9e11d806c1d6c0b54fe61922bb419d90c94cd93e374ce')
+b2sums=('ad5615b6a45dc5cd1a0128a6a6a48b0b29a4f56b753869c55018913a9047d712a028ed74a8fa2fcee36cc851f1c0f85a9f4ddf7c7aa1f5e3b28b09761c511aea')
prepare() {
cd "${srcdir}"/${_pkgname}-${pkgver}