summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroger2016-06-23 14:33:25 -0300
committerroger2016-06-23 14:33:25 -0300
commit30f6c717176a02538161875983aab856daf7a82f (patch)
treed770ee1b3c61077637b686f910642af0541b1bb3
downloadaur-30f6c717176a02538161875983aab856daf7a82f.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..481cc4d04098
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-httpie-jwt-auth
+ pkgdesc = JWTAuth (JSON Web Tokens) auth plugin for HTTPie
+ pkgver = 50.3a2ce34
+ pkgrel = 1
+ url = https://github.com/teracyhq/httpie-jwt-auth
+ arch = any
+ license = BSD
+ makedepends = python-distribute
+ makedepends = git
+ depends = httpie
+ source = python-httpie-jwt-auth::git://github.com/teracyhq/httpie-jwt-auth.git
+ md5sums = SKIP
+
+pkgname = python-httpie-jwt-auth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d37a3d623737
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Roger Duran <rogerduran at gmail dot com>
+
+pkgname=python-httpie-jwt-auth
+pkgdesc="JWTAuth (JSON Web Tokens) auth plugin for HTTPie"
+license=('BSD')
+url="https://github.com/teracyhq/httpie-jwt-auth"
+pkgver=50.3a2ce34
+pkgrel=1
+
+source=("$pkgname::git://github.com/teracyhq/httpie-jwt-auth.git")
+md5sums=('SKIP')
+depends=('httpie')
+makedepends=('python-distribute' 'git')
+arch=('any')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}