summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvan Purkhsier2014-08-12 13:52:45 -0700
committerEvan Purkhsier2014-08-12 13:52:45 -0700
commit93b3c34084df8e58d237a3650dae78799ecb585b (patch)
tree5d0228b5cd860adbc3807c3e31795c043388a198
downloadaur-93b3c34084df8e58d237a3650dae78799ecb585b.tar.gz
New pkg: python-httpie-oauth
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b12c84b7ebab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-httpie-oauth
+ pkgdesc = OAuth plugin for httpie
+ pkgver = 5.6cf6ed4
+ pkgrel = 1
+ url = https://github.com/jakubroztocil/httpie-oauth
+ arch = any
+ license = BSD
+ makedepends = python-distribute
+ makedepends = git
+ depends = python-oauthlib
+ source = git://github.com/jakubroztocil/httpie-oauth.git
+ md5sums = SKIP
+
+pkgname = python-httpie-oauth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5ece1dd98b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Thomas Weißschuh <thomas_weissschuh lavabit com>
+
+_gitname=httpie-oauth
+pkgname=python-httpie-oauth
+pkgver=5.6cf6ed4
+pkgrel=1
+pkgdesc="OAuth plugin for httpie"
+url="https://github.com/jakubroztocil/httpie-oauth"
+source=(git://github.com/jakubroztocil/httpie-oauth.git)
+depends=(python-oauthlib)
+makedepends=(python-distribute git)
+md5sums=('SKIP')
+license=('BSD')
+arch=('any')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}