summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2018-07-01 13:22:41 -0400
committerAndrew O'Neill2018-07-01 13:22:41 -0400
commit2edd0726d8f8b1146b9e13f5b660612c47deb73c (patch)
treeb6f82d3c8550a3259c29999036b42595eb81cce1
downloadaur-python-httpsig_cffi.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62bcac104b86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-httpsig_cffi
+ pkgdesc = Sign HTTP requests with secure signatures according to the IETF HTTP Signatures specification using Cryptography
+ pkgver = 15.0.0
+ pkgrel = 1
+ url = https://github.com/hawkowl/httpsig_cffi
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ depends = python-cryptography
+ source = https://github.com/hawkowl/httpsig_cffi/archive/v15.0.0.tar.gz
+ sha256sums = d3d700429c4672a87c149e0be4248ec1e5898d689feb9e959529f0d32df72c3f
+
+pkgname = python-httpsig_cffi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18f975240fb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+
+pkgname=python-httpsig_cffi
+_pyname=httpsig_cffi
+pkgver=15.0.0
+pkgrel=1
+pkgdesc='Sign HTTP requests with secure signatures according to the IETF HTTP Signatures specification using Cryptography'
+arch=('any')
+url='https://github.com/hawkowl/httpsig_cffi'
+license=('MIT')
+depends=('python' 'python-six' 'python-cryptography')
+makedepends=('python-setuptools')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('d3d700429c4672a87c149e0be4248ec1e5898d689feb9e959529f0d32df72c3f')
+
+build() {
+ cd "${_pyname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${_pyname}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}