summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormdraw2016-12-21 17:54:51 +0100
committermdraw2016-12-21 17:54:51 +0100
commit48269f6785f86c944054760e7eabdbece50c72ac (patch)
treecb33729b65b6c3a73d66d7e87871b304f9c517a0
downloadaur-48269f6785f86c944054760e7eabdbece50c72ac.tar.gz
0.0.9
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9b031bceaac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Dec 21 16:54:12 UTC 2016
+pkgbase = python-httptools
+ pkgdesc = Fast HTTP parser
+ pkgver = 0.0.9
+ pkgrel = 1
+ url = https://github.com/MagicStack/httptools
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = cython
+ depends = python
+ source = https://github.com/MagicStack/httptools/archive/v0.0.9.tar.gz
+ md5sums = 7f5c62a9d7fed2cb31887d6068006d83
+
+pkgname = python-httptools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f1542081148
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: mdraw.gh at gmail dot com
+
+# If anyone knows how to make the http-parser submodule work
+# without this ugly hack in package(), please tell me!
+
+pkgname=('python-httptools')
+pkgver='0.0.9'
+pkgrel=1
+pkgdesc='Fast HTTP parser'
+arch=('any')
+url='https://github.com/MagicStack/httptools'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools' 'cython')
+source=("https://github.com/MagicStack/httptools/archive/v${pkgver}.tar.gz")
+md5sums=('7f5c62a9d7fed2cb31887d6068006d83')
+
+package_python-httptools() {
+ cd "${srcdir}/httptools-${pkgver}"
+
+ # Git submodule workaround
+ pushd vendor
+ rm -rf http-parser
+ git clone https://github.com/nodejs/http-parser.git
+ pushd http-parser
+ git checkout '9b0d5b3' # re-check this hash when updating
+ popd
+ popd
+
+ cython httptools/parser/parser.pyx
+ python setup.py install --root="${pkgdir}" --optimize=1
+}