summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Hill2022-05-25 15:04:24 +0100
committerTristan Hill2022-05-25 15:04:24 +0100
commit7a4b3b07bf2e7d0878c9aba9238a7f972d6e9dd6 (patch)
treebf344e72a4e9e2c91906374dd333566f536e50ca
parentde1c0b0844cb8b994ef62c2def382d26b648c045 (diff)
downloadaur-7a4b3b07bf2e7d0878c9aba9238a7f972d6e9dd6.tar.gz
update PKGBUILD similar to python-httpx
-rw-r--r--PKGBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d5f634bd7cb..2ada6ca2cc93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,25 @@
-# Maintainer : Kr1ss $(tr +- .@ <<<'<kr1ss+x-yandex+com>')
-
-
-pkgname=python-httpx-socks
-_name="${pkgname#python-}"
-
+_pkgname=httpx-socks
+pkgname=python-$_pkgname
epoch=1
pkgver=0.7.4
pkgrel=1
-
pkgdesc='HTTP/SOCKS-proxy transports for httpx'
arch=('any')
-url="https://pypi.org/project/$_name"
+url="https://github.com/romis2012/$_pkgname"
license=('Apache')
-
makedepends=('python-setuptools')
-depends=('python' 'python-python-socks' 'python-httpcore' 'python-httpx')
+depends=( 'python-python-socks' 'python-httpcore' 'python-httpx')
optdepends=('python-async-timeout' 'python-trio' 'python-curio')
-
-source=("$_name-$pkgver.tgz::https://github.com/romis2012/$_name/archive/refs/tags/v$pkgver.tar.gz")
+source=("$_pkgname-$pkgver.tgz::https://github.com/romis2012/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('721c0c85c9ab95351f140fb68b63f42589a31f060fc150472554955c491d24d0')
-
build() {
- cd "$_name-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$_name-$pkgver"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --prefix=/usr --skip-build
+ cd "$_pkgname-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 --skip-build
install -Dm644 README.md -t"$pkgdir/usr/share/doc/$pkgname/"
}
-
-
-# vim: ts=2 sw=2 et ft=PKGBUILD: