summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreschwartz2020-07-10 14:18:29 +0000
committerJakob Gahde2022-01-05 11:49:46 +0100
commit060dca6f0e8d736bfb902b0b52b3cdab11486b2c (patch)
tree43c221e935bbb275f034136cc023facbfa91b134
downloadaur-060dca6f0e8d736bfb902b0b52b3cdab11486b2c.tar.gz
addpkg: python-httpx 0.13.3-4: dependency of authlib
git-svn-id: file:///srv/repos/svn-community/svn@663105 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe37e506a06a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-httpx
+ pkgdesc = A next generation HTTP client for Python
+ pkgver = 0.13.3
+ pkgrel = 4
+ url = https://github.com/encode/httpx
+ arch = any
+ license = BSD
+ checkdepends = python-pytest-asyncio
+ checkdepends = python-pytest-trio
+ checkdepends = python-brotli
+ checkdepends = python-trustme
+ checkdepends = uvicorn
+ makedepends = python-setuptools
+ depends = python-certifi
+ depends = python-chardet
+ depends = python-hstspreload
+ depends = python-httpcore
+ depends = python-idna
+ depends = python-rfc3986
+ depends = python-sniffio
+ optdepends = python-brotli: for brotli response decompression
+ source = python-httpx-0.13.3.tar.gz::https://github.com/encode/httpx/archive/0.13.3.tar.gz
+ sha512sums = 54cdee16e8253c221c3298817ccf63a4a0d6755a86feea2aa5a2efe9af44eb1eb0a578b21f593fe28fceace17b0a0badb52a66965c35bf456ea57dd3b905ebbe
+ b2sums = d3a56c2386841909668e34eaa78d202f91ad900230b9d1d4254bfa08312312d020e081aea2839dbb57d85fa26ccfc3f093404801c4dd5c47051f3c9fd2746552
+
+pkgname = python-httpx
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec4efde468e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+
+_pkgname=httpx
+pkgname=python-httpx
+pkgver=0.13.3
+pkgrel=4
+pkgdesc="A next generation HTTP client for Python"
+arch=('any')
+url="https://github.com/encode/${_pkgname}"
+license=('BSD')
+depends=('python-certifi' 'python-chardet' 'python-hstspreload' 'python-httpcore' 'python-idna' 'python-rfc3986' 'python-sniffio')
+optdepends=('python-brotli: for brotli response decompression')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-brotli' 'python-trustme' 'uvicorn')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha512sums=('54cdee16e8253c221c3298817ccf63a4a0d6755a86feea2aa5a2efe9af44eb1eb0a578b21f593fe28fceace17b0a0badb52a66965c35bf456ea57dd3b905ebbe')
+b2sums=('d3a56c2386841909668e34eaa78d202f91ad900230b9d1d4254bfa08312312d020e081aea2839dbb57d85fa26ccfc3f093404801c4dd5c47051f3c9fd2746552')
+
+prepare() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ # do not run coverage in unittests!
+ sed -i '/^addopts/d' setup.cfg
+}
+
+build() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ python -m pytest
+}
+
+package() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.md
+}