summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-08-08 12:45:55 -0600
committerAinola2015-08-08 12:45:55 -0600
commit3afa1efeb8d49e8ee5657fb9050eaa5bf1c43e07 (patch)
treea5989ef7d7a507afdd3a260b3ec9f5cffaf410b9
downloadaur-3afa1efeb8d49e8ee5657fb9050eaa5bf1c43e07.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b54ac6f5e33a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-humblebundle
+ pkgdesc = An unofficial library for querying the Humble Bundle API
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/saik0/humblebundle-python
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-requests
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/h/humblebundle/humblebundle-0.1.1.tar.gz
+ sha256sums = 82f7724c286abff1dae6586501ac6a30ea4905652006c7e57d68e03450881222
+
+pkgname = python-humblebundle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf759aaf83b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Ainola
+# Contributor: Hugo Osvaldo Barrera
+# Contributor: Joel Pedraza
+
+pkgname=python-humblebundle
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="An unofficial library for querying the Humble Bundle API"
+arch=('any')
+url="https://github.com/saik0/humblebundle-python"
+license=('MIT')
+depends=('python-requests')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/h/${pkgname:7}/${pkgname:7}-${pkgver}.tar.gz")
+sha256sums=('82f7724c286abff1dae6586501ac6a30ea4905652006c7e57d68e03450881222')
+
+package() {
+ cd "${srcdir}/${pkgname:7}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}