summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-11-06 04:44:42 -0700
committerAinola2018-11-06 04:44:42 -0700
commitcab9477dbfca5b9416b92a70ee6082c57629ebc4 (patch)
tree7ea08239a21677a5711969cdbc0c8bc8e0aa50d1
parent20b5f499d0d05eb2e6d8d4be203eb77721007278 (diff)
downloadaur-cab9477dbfca5b9416b92a70ee6082c57629ebc4.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43dbad7072f0..f968310ac9f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-# Generated by mksrcinfo v8
-# Mon Sep 3 06:27:55 UTC 2018
pkgbase = python-humblebundle
pkgdesc = An unofficial library for querying the Humble Bundle API
pkgver = 0.1.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/saik0/humblebundle-python
arch = any
license = MIT
makedepends = python-setuptools
depends = python-requests
options = !emptydirs
- source = https://pypi.python.org/packages/source/h/humblebundle/humblebundle-0.1.1.tar.gz
- source = https://raw.githubusercontent.com/saik0/humblebundle-python/master/LICENSE
- sha256sums = 82f7724c286abff1dae6586501ac6a30ea4905652006c7e57d68e03450881222
- sha256sums = e54a169f0f2f1cd1039077ef77e5566dfea2cedc61ccf1ab560b2f4c1a1b8025
+ source = python-humblebundle-0.1.1::https://github.com/saik0/humblebundle-python/archive/0.1.1.tar.gz
+ sha256sums = 51afe971fa66d1da43c574d0bbe117abd3c6b6a0351b4273dd97ffb3d1a031bf
pkgname = python-humblebundle
diff --git a/PKGBUILD b/PKGBUILD
index 656366829948..f8eb8334bb28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: Joel Pedraza
pkgname=python-humblebundle
+_upstream_name=humblebundle-python
pkgver=0.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="An unofficial library for querying the Humble Bundle API"
arch=('any')
url="https://github.com/saik0/humblebundle-python"
@@ -12,21 +13,18 @@ license=('MIT')
depends=('python-requests')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/h/${pkgname:7}/${pkgname:7}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/saik0/humblebundle-python/master/LICENSE")
-sha256sums=('82f7724c286abff1dae6586501ac6a30ea4905652006c7e57d68e03450881222'
- 'e54a169f0f2f1cd1039077ef77e5566dfea2cedc61ccf1ab560b2f4c1a1b8025')
+source=("$pkgname-$pkgver::https://github.com/saik0/humblebundle-python/archive/$pkgver.tar.gz")
+sha256sums=('51afe971fa66d1da43c574d0bbe117abd3c6b6a0351b4273dd97ffb3d1a031bf')
build() {
- cd "humblebundle-$pkgver"
+ cd "$_upstream_name-$pkgver"
python setup.py build
}
package() {
- # LICENSE file is not included in releases
+ cd "$_upstream_name-$pkgver"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm644 "humblebundle-$pkgver"/README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
- cd "humblebundle-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}