summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlesebas2022-01-22 19:49:59 +0100
committerlesebas2022-01-22 19:49:59 +0100
commitc52674b894bb1a034aa767350c7d3084589ef45a (patch)
tree8b12a06d5a16e074db0d4fbd3e63adaea3731758
parent70e1da4cfe507c0085f0cdb7c45070a06cc7040d (diff)
downloadaur-c52674b894bb1a034aa767350c7d3084589ef45a.tar.gz
update to 0.9_4
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD7
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99d7dafa8347..4c1171cfd9c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Wed Nov 15 21:05:53 UTC 2017
pkgbase = python-hurry-filesize
pkgdesc = A simple Python library for human readable file sizes (or anything sized in bytes).
pkgver = 0.9
@@ -7,10 +5,10 @@ pkgbase = python-hurry-filesize
url = http://pypi.python.org/pypi/hurry.filesize/
arch = any
license = GPL
- makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-wheel
depends = python
- source = https://pypi.python.org/packages/source/h/hurry.filesize/hurry.filesize-0.9.tar.gz
+ source = https://files.pythonhosted.org/packages/ee/5e/16e17bedcf54d5b618dc0771690deda77178e5c310402881c3d2d6c5f27c/hurry.filesize-0.9.tar.gz
md5sums = 8549ccd09bb31b5ff1e8e8c1eacc7794
pkgname = python-hurry-filesize
-
diff --git a/PKGBUILD b/PKGBUILD
index 40a82c65c3d1..613a38d7728f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,11 @@ arch=('any')
url="http://pypi.python.org/pypi/hurry.filesize/"
license=('GPL')
depends=('python')
-makedepends=('python-setuptools')
-source=("https://pypi.python.org/packages/source/h/hurry.filesize/hurry.filesize-$pkgver.tar.gz")
+makedepends=('python-pip' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/ee/5e/16e17bedcf54d5b618dc0771690deda77178e5c310402881c3d2d6c5f27c/hurry.filesize-0.9.tar.gz")
md5sums=('8549ccd09bb31b5ff1e8e8c1eacc7794')
package() {
- cd "$srcdir/hurry.filesize-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m pip install ./hurry.filesize-0.9.tar.gz
}