summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbitcoinlizard2021-05-14 22:58:12 -0500
committerbitcoinlizard2021-05-14 22:58:12 -0500
commit62ac8aea5f7c59ee082d1f3a44f71b95e8a45795 (patch)
tree29a4b883e5c0f2477c245bb535f8ad23fc9479ac
downloadaur-62ac8aea5f7c59ee082d1f3a44f71b95e8a45795.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbc639746468
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-hwilib
+ pkgdesc = The Bitcoin Hardware Wallet Interface is a Python library and command line tool for interacting with hardware wallets.
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/bitcoin-core/HWI
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = libusb
+ depends = systemd-libs
+ depends = python-libusb1
+ depends = python-base58
+ depends = python-bitbox02
+ depends = python-hidapi
+ depends = python-cryptography
+ depends = python-mnemonic
+ source = https://github.com/bitcoin-core/HWI/archive/refs/tags/2.0.1.tar.gz
+ sha256sums = e758f4b83928a4d71b7541958ac6c130cc137e14161942fdec8c812afb2130db
+
+pkgname = python-hwilib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d579f26fdc0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: bitcoinlizard <bitcoinlizard@fastmail.com>
+
+pkgname=python-hwilib
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="The Bitcoin Hardware Wallet Interface is a Python library and command line tool for interacting with hardware wallets."
+arch=('any')
+url="https://github.com/bitcoin-core/HWI"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python' 'libusb' 'systemd-libs' 'python-libusb1' 'python-base58' 'python-bitbox02' 'python-hidapi' 'python-cryptography' 'python-mnemonic')
+
+source=("https://github.com/bitcoin-core/HWI/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('e758f4b83928a4d71b7541958ac6c130cc137e14161942fdec8c812afb2130db')
+
+prepare() {
+ cd "HWI-${pkgver}"
+}
+
+build() {
+ cd "HWI-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "HWI-${pkgver}"
+
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # Install license since the package doesn't include it
+ install -Dm 644 "$srcdir/HWI-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}