summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Zhe2018-09-10 12:44:46 +0800
committerLiu Zhe2018-09-10 12:44:46 +0800
commitdff1ed052cf3f646bc4c5bd059ccd0e562b5a00f (patch)
tree771e806254e52d62838403f6119c46341e8361fc
downloadaur-dff1ed052cf3f646bc4c5bd059ccd0e562b5a00f.tar.gz
create
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..731a6a014d8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-hyperopt
+ pkgdesc = Distributed Asynchronous Hyperparameter Optimization in Python
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/hyperopt/hyperopt
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python-scipy
+ depends = python-pymongo
+ depends = python-six
+ depends = python-networkx
+ depends = python-future
+ source = hyperopt-0.1.1.tar.gz::https://github.com/hyperopt/hyperopt/archive/0.1.1.tar.gz
+ sha1sums = 98b36f8c42586574524f693b1f8982b1b05b5225
+
+pkgname = python-hyperopt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39c44f037013
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Liu Zhe <cruise.pas@gmail.com>
+
+pkgname=python-hyperopt
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Distributed Asynchronous Hyperparameter Optimization in Python'
+arch=('any')
+url='https://github.com/hyperopt/hyperopt'
+license=('custom')
+depends=('python-scipy' 'python-pymongo' 'python-six' 'python-networkx' 'python-future')
+makedepends=('python-setuptools')
+source=("hyperopt-$pkgver.tar.gz::https://github.com/hyperopt/hyperopt/archive/$pkgver.tar.gz")
+sha1sums=('98b36f8c42586574524f693b1f8982b1b05b5225')
+
+build() {
+ cd "$srcdir"/hyperopt-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/hyperopt-$pkgver
+ python setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}