summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjlaehne2023-05-08 10:16:19 +0200
committerjlaehne2023-05-08 10:16:19 +0200
commit16e8bc988bbf23edc22d9cc3f1c074b044f74b9c (patch)
treeff5d0884999ebdce9eccfe66cc1cc8fc58015202
parent55acfc5643ce0ca6bf89e99e106d940c52725343 (diff)
downloadaur-16e8bc988bbf23edc22d9cc3f1c074b044f74b9c.tar.gz
Provides hyperspy 1.7.5
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 858894e011e5..5a3d58cfd1a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-hyperspy
pkgdesc = Hyperspectral data analysis
- pkgver = 1.7.4
- pkgrel = 2
+ pkgver = 1.7.5
+ pkgrel = 1
url = http://hyperspy.org
arch = any
license = GPL3
@@ -16,7 +16,7 @@ pkgbase = python-hyperspy
depends = python
depends = python-scipy>=1.4.0
depends = python-matplotlib>=3.1.3
- depends = python-numpy>=1.17.1
+ depends = python-numpy>=1.19.0
depends = python-traits>=4.5.0
depends = python-natsort
depends = python-requests
@@ -27,7 +27,8 @@ pkgbase = python-hyperspy
depends = python-packaging
depends = python-dateutil>=2.5.0
depends = ipython>=8.1.0
- depends = python-dask>2.1.0
+ depends = python-dask>2.11.0
+ depends = python-fsspec
depends = python-pint>=0.10
depends = python-numexpr
depends = python-pyaml
@@ -38,10 +39,8 @@ pkgbase = python-hyperspy
depends = python-ipyparallel
depends = python-scikit-image>=0.15
depends = python-sparse
- depends = python-zarr
+ depends = python-zarr>=2.9.0
depends = python-tifffile>=2020.2.16
- depends = python-numba>=0.52
- depends = python-llvmlite
optdepends = python-scikit-learn>=1.0.1: machine learning features
optdepends = python-hyperspy-gui-ipywidgets: GUI components for Jupyter
optdepends = python-hyperspy-gui-traitsui: GUI components for desktop
@@ -54,7 +53,7 @@ pkgbase = python-hyperspy
provides = hyperspy
conflicts = hyperspy
replaces = hyperspy
- source = https://github.com/hyperspy/hyperspy/archive/v1.7.4.tar.gz
- md5sums = 684d0b691fb368f2a38778d46ee4b699
+ source = https://github.com/hyperspy/hyperspy/archive/v1.7.5.tar.gz
+ md5sums = bed260ef9398c5b309f99d7cc681cb82
pkgname = python-hyperspy
diff --git a/PKGBUILD b/PKGBUILD
index 8122ed3e175e..6b4dfc28e157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Maintainer: Joshua Taillon <jat255 AT gmail DOT com>
pkgname=python-hyperspy
pkgshort=hyperspy
-pkgver=1.7.4
-pkgrel=2
+pkgver=1.7.5
+pkgrel=1
pkgdesc="Hyperspectral data analysis"
arch=('any')
url="http://hyperspy.org"
@@ -13,7 +13,7 @@ license=('GPL3')
depends=('python'
'python-scipy>=1.4.0'
'python-matplotlib>=3.1.3'
- 'python-numpy>=1.17.1'
+ 'python-numpy>=1.19.0'
'python-traits>=4.5.0'
'python-natsort'
'python-requests'
@@ -24,7 +24,8 @@ depends=('python'
'python-packaging'
'python-dateutil>=2.5.0'
'ipython>=8.1.0'
- 'python-dask>2.1.0'
+ 'python-dask>2.11.0'
+ 'python-fsspec'
'python-pint>=0.10'
'python-numexpr'
'python-pyaml'
@@ -35,12 +36,12 @@ depends=('python'
'python-ipyparallel' # AUR
'python-scikit-image>=0.15' # AUR
'python-sparse' # AUR
- 'python-zarr' # AUR
+ 'python-zarr>=2.9.0' # AUR
+ 'python-tifffile>=2020.2.16' # AUR (from scikit-image)
# 'python-imageio' # AUR (from scikit-image)
# 'python-pywavelets' # AUR (from scikit-image)
- 'python-tifffile>=2020.2.16' # AUR (from scikit-image)
- 'python-numba>=0.52' # AUR (from python-sparse, but currently requires git version)
- 'python-llvmlite' # AUR (from python-numba, but currently requires git version)
+ # 'python-numba>=0.52' # AUR (from python-sparse, but currently requires git version)
+ # 'python-llvmlite' # AUR (from python-numba, but currently requires git version)
)
optdepends=('python-scikit-learn>=1.0.1: machine learning features'
@@ -76,4 +77,4 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1
}
-md5sums=('684d0b691fb368f2a38778d46ee4b699')
+md5sums=('bed260ef9398c5b309f99d7cc681cb82')