summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjlaehne2023-03-28 11:02:43 +0200
committerjlaehne2023-03-28 11:02:43 +0200
commit3aa840aa590e1f27820bb4316c05a0127405cd65 (patch)
treea939a112c321175575765807455c5e51ba3076f9
parent16c3ae6d8a995a63ea07bede5757e020608efdd2 (diff)
downloadaur-3aa840aa590e1f27820bb4316c05a0127405cd65.tar.gz
Provides hyperspy 1.7.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be4800e8f1a2..f2c123a8b536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-hyperspy
pkgdesc = Hyperspectral data analysis
- pkgver = 1.7.3
+ pkgver = 1.7.4
pkgrel = 1
url = http://hyperspy.org
arch = any
@@ -10,9 +10,11 @@ pkgbase = python-hyperspy
checkdepends = python-pytest-xdist
checkdepends = python-pytest-rerunfailures
checkdepends = python-pytest-cov
+ checkdepends = python-matplotlib>=3.1
+ checkdepends = python-pooch
makedepends = python-setuptools
depends = python
- depends = python-scipy>=1.1
+ depends = python-scipy>=1.4.0
depends = python-matplotlib>=3.1.3
depends = python-numpy>=1.17.1
depends = python-traits>=4.5.0
@@ -40,7 +42,7 @@ pkgbase = python-hyperspy
depends = python-tifffile>=2020.2.16
depends = python-numba-git>=0.52
depends = python-llvmlite-git
- optdepends = python-scikit-learn: machine learning features
+ optdepends = python-scikit-learn>=1.0.1: machine learning features
optdepends = python-hyperspy-gui-ipywidgets: GUI components for Jupyter
optdepends = python-hyperspy-gui-traitsui: GUI components for desktop
optdepends = python-blosc>=1.5: mrcz file support
@@ -52,7 +54,7 @@ pkgbase = python-hyperspy
provides = hyperspy
conflicts = hyperspy
replaces = hyperspy
- source = https://github.com/hyperspy/hyperspy/archive/v1.7.3.tar.gz
- md5sums = 9f3d9d99fb4c6c5a21fcc4c399cedc73
+ source = https://github.com/hyperspy/hyperspy/archive/v1.7.4.tar.gz
+ md5sums = 684d0b691fb368f2a38778d46ee4b699
pkgname = python-hyperspy
diff --git a/PKGBUILD b/PKGBUILD
index 5cc1898bed8a..472a15a5ff01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Joshua Taillon <jat255 AT gmail DOT com>
pkgname=python-hyperspy
pkgshort=hyperspy
-pkgver=1.7.3
+pkgver=1.7.4
pkgrel=1
pkgdesc="Hyperspectral data analysis"
arch=('any')
@@ -11,7 +11,7 @@ url="http://hyperspy.org"
license=('GPL3')
depends=('python'
- 'python-scipy>=1.1'
+ 'python-scipy>=1.4.0'
'python-matplotlib>=3.1.3'
'python-numpy>=1.17.1'
'python-traits>=4.5.0'
@@ -43,7 +43,7 @@ depends=('python'
'python-llvmlite-git' # AUR (from python-numba, but currently requires git version)
)
-optdepends=('python-scikit-learn: machine learning features'
+optdepends=('python-scikit-learn>=1.0.1: machine learning features'
'python-hyperspy-gui-ipywidgets: GUI components for Jupyter' # AUR
'python-hyperspy-gui-traitsui: GUI components for desktop' # AUR
'python-blosc>=1.5: mrcz file support'
@@ -61,6 +61,8 @@ checkdepends=('python-pytest>=3.6'
'python-pytest-xdist'
'python-pytest-rerunfailures'
'python-pytest-cov'
+ 'python-matplotlib>=3.1'
+ 'python-pooch'
)
replaces=('hyperspy')
@@ -74,4 +76,4 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1
}
-md5sums=('9f3d9d99fb4c6c5a21fcc4c399cedc73')
+md5sums=('684d0b691fb368f2a38778d46ee4b699')