summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-08-09 10:52:53 +0200
committerwillemw122015-08-15 15:22:38 +0200
commit27fa6834d06c0bb9d6ab76e3f43c60e5165e453e (patch)
tree7ea954516c4f6f38f2867ad17f007440ae814c6c
parent09794adacc2bbf149df5ab5413ba69f2f5fca471 (diff)
downloadaur-27fa6834d06c0bb9d6ab76e3f43c60e5165e453e.tar.gz
Created split package (python 2 and 3)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD55
2 files changed, 55 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edbe282c4546..d8aec7561433 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,13 +6,19 @@ pkgbase = python-i3-git
arch = any
license = GPL3
makedepends = git
+ options = !emptydirs
+ source = python-i3::git://github.com/ziberna/i3-py.git
+ md5sums = SKIP
+
+pkgname = python-i3-git
depends = python
depends = i3-wm
provides = python-i3
conflicts = python-i3
- options = !emptydirs
- source = python-i3-git::git://github.com/ziberna/i3-py.git
- md5sums = SKIP
-pkgname = python-i3-git
+pkgname = python2-i3-git
+ depends = python2
+ depends = i3-wm
+ provides = python-i3
+ conflicts = python-i3
diff --git a/PKGBUILD b/PKGBUILD
index 17d421ac6a0e..f9135d41ff80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,70 @@
# Contributor: Anntoin Wilkinson <anntoin gmail com>
_pkgname=python-i3
-pkgname=$_pkgname-git
+_pkgname2=python2-i3
+pkgbase=$_pkgname-git
+pkgname=($_pkgname-git $_pkgname2-git)
pkgver=r156.27f88a6
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for i3 users and Python developers"
arch=('any')
url="https://github.com/ziberna/i3-py"
license=('GPL3')
-provides=($_pkgname)
-conflicts=($_pkgname)
-depends=('python' 'i3-wm')
+#makedepends=('git' 'python' 'python2')
makedepends=('git')
options=(!emptydirs)
-source=($pkgname::git://github.com/ziberna/i3-py.git)
+source=($_pkgname::git://github.com/ziberna/i3-py.git)
md5sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd $_pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
- cd $pkgname
+prepare() {
+ rm -rf $_pkgname2
+ cp -a $_pkgname $_pkgname2
+}
+
+#build() {
+# cd "$srcdir/$_pkgname"
+# python setup.py build
+#
+# cd "$srcdir/$_pkgname2"
+# python2 setup.py build
+#}
+
+package_python-i3-git() {
+ _pkgname=python-i3
+ provides=($_pkgname)
+ conflicts=($_pkgname)
+ depends=('python' 'i3-wm')
+
+ cd $_pkgname
python setup.py install --root="$pkgdir/" --optimize=1
# Install some of the useful examples
cd examples
for file in ipc.py scratcher.py winmenu.py wsbar.py
do
- install -Dm 755 "$file" "$pkgdir/usr/bin/i3-${file%.py}"
+ install -Dm755 "$file" "$pkgdir/usr/bin/i3-${file%.py}"
+ done
+}
+
+package_python2-i3-git() {
+ _pkgname=python2-i3
+ provides=($_pkgname)
+ conflicts=($_pkgname)
+ depends=('python2' 'i3-wm')
+
+ cd $_pkgname
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ # Install some of the useful examples
+ cd examples
+ for file in ipc.py scratcher.py winmenu.py wsbar.py
+ do
+ install -Dm755 "$file" "$pkgdir/usr/bin/i3-${file%.py}2"
done
}