summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustahuman12020-06-05 01:08:05 -0700
committerjustahuman12020-06-05 01:08:05 -0700
commit7de65ffcde164406978e5fcd0a4afb8b415b3340 (patch)
treeba8dc10552d28003b06d4b67169a20653f989900
downloadaur-7de65ffcde164406978e5fcd0a4afb8b415b3340.tar.gz
Stable AUR Build | 0.2.3b2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6575abf3cea0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-i3-grid
+ pkgdesc = A i3wm grid controller for floating window automation.
+ pkgver = 0.2.3b2
+ pkgrel = 1
+ url = https://github.com/justahuman1/i3-grid
+ arch = any
+ license = GPL3
+ makedepends = python3
+ depends = python-i3-py
+ source = https://files.pythonhosted.org/packages/ac/2a/f38475c92a041093756f693fce47a7ed17ca46acda8f6f3785b66cdf0623/i3-grid-0.2.3b2.tar.gz
+ md5sums = 2d58b731d962ab2a885a7efabce7c65a
+
+pkgname = python-i3-grid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..847c1506866a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sai Valla <saivdev@protonmail.com>
+
+pkgname=python-i3-grid
+pkgver=0.2.3b2
+pkgrel=1
+epoch=
+pkgdesc='A i3wm grid controller for floating window automation.'
+arch=(any)
+url="https://github.com/justahuman1/i3-grid"
+license=('GPL3')
+groups=()
+depends=('python-i3-py')
+makedepends=('python3' )
+checkdepends=()
+conflicts=(${provides%=*}) # No quotes, to avoid an empty entry.
+source=('https://files.pythonhosted.org/packages/ac/2a/f38475c92a041093756f693fce47a7ed17ca46acda8f6f3785b66cdf0623/i3-grid-0.2.3b2.tar.gz')
+md5sums=('2d58b731d962ab2a885a7efabce7c65a')
+
+build() {
+ cd $srcdir/i3-grid-0.2.3b2
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/i3-grid-0.2.3b2
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+