summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoribrokemypie2020-10-29 10:14:06 +1100
committeribrokemypie2020-10-29 10:14:06 +1100
commit1646d802c569e84e76a250e6d6c2e0f3cee2b808 (patch)
tree10a03f72c2486fac12d3ac25e8cbef3784a3dae8
downloadaur-1646d802c569e84e76a250e6d6c2e0f3cee2b808.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26f05eda2d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-i3-quickterm
+ pkgdesc = A small drop-down terminal for i3wm and sway
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://pypi.org/project/i3-quickterm/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-i3ipc
+ optdepends = i3
+ optdepends = sway
+ optdepends = dmenu
+ optdepends = rofi
+ source = i3-quickterm-1.0.tar.gz::https://github.com/lbonn/i3-quickterm/archive/v1.0.tar.gz
+ sha256sums = aa3ab2a31713b1868e37101be2edf852eb9727110c0beaab1772c97caf1b1437
+
+pkgname = python-i3-quickterm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e36131eb6d01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: ibrokemypie <ibrokemypie@bastardi.net>
+pkgname=python-i3-quickterm
+_name=${pkgname#python-}
+pkgver=1.0
+pkgrel=1
+pkgdesc="A small drop-down terminal for i3wm and sway"
+arch=('any')
+url='https://pypi.org/project/i3-quickterm/'
+license=('MIT')
+depends=('python' 'python-i3ipc')
+makedepends=('python-setuptools')
+optdepends=('i3' 'sway' 'dmenu' 'rofi')
+source=("$_name-$pkgver.tar.gz::https://github.com/lbonn/$_name/archive/v${pkgver}.tar.gz")
+sha256sums=('aa3ab2a31713b1868e37101be2edf852eb9727110c0beaab1772c97caf1b1437')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}