summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2023-07-12 21:42:32 +0300
committerAnton Kudelin2023-07-12 21:42:32 +0300
commit4a78e52686244bf3c26c60a6c4141a33a74b7e6e (patch)
treeb468357d2a3002d3ff3235e0985323ec6796caa6
downloadaur-4a78e52686244bf3c26c60a6c4141a33a74b7e6e.tar.gz
initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3065cfe4c39f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-ib-insync
+ pkgdesc = Python sync/async framework for Interactive Brokers API
+ pkgver = 0.9.86
+ pkgrel = 1
+ url = https://github.com/erdewit/ib_insync
+ arch = any
+ license = BSD
+ checkdepends = python-pytest-asyncio
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-nest-asyncio
+ depends = python-eventkit
+ depends = python-pandas
+ depends = python-matplotlib
+ conflicts = python-ib-insync-git
+ source = https://files.pythonhosted.org/packages/55/bb/733d5c81c8c2f54e90898afc7ff3a99f4d53619e6917c848833f9cc1ab56/ib_insync-0.9.86.tar.gz
+ sha256sums = 73af602ca2463f260999970c5bd937b1c4325e383686eff301743a4de08d381e
+
+pkgname = python-ib-insync
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5ccb0eaab61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Anton Kudelin <kudelin at proton dot me>
+
+_pyname=ib-insync
+pkgname=python-$_pyname
+pkgver=0.9.86
+pkgrel=1
+pkgdesc='Python sync/async framework for Interactive Brokers API'
+arch=(any)
+url='https://github.com/erdewit/ib_insync'
+license=(BSD)
+depends=(python-nest-asyncio python-eventkit python-pandas python-matplotlib)
+makedepends=(python-setuptools python-build python-installer python-wheel)
+checkdepends=(python-pytest-asyncio)
+conflicts=($pkgname-git)
+source=(https://files.pythonhosted.org/packages/55/bb/733d5c81c8c2f54e90898afc7ff3a99f4d53619e6917c848833f9cc1ab56/${_pyname/-/_}-${pkgver}.tar.gz)
+sha256sums=('73af602ca2463f260999970c5bd937b1c4325e383686eff301743a4de08d381e')
+
+build() {
+ cd "${srcdir}/${_pyname/-/_}-${pkgver}"
+ python -m build \
+ --wheel \
+ --no-isolation \
+ --skip-dependency-check
+}
+
+package() {
+ cd "${srcdir}/${_pyname/-/_}-${pkgver}"
+ python -m installer \
+ --destdir="$pkgdir" \
+ --compile-bytecode=2 \
+ dist/*.whl
+
+ install -Dm755 LICENSE \
+ -t "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}