summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2017-06-24 23:37:40 -0400
committerDaniel M. Capella2017-06-24 23:37:40 -0400
commit171e9f1e92e998302b7945dc1269c890f3c25e3a (patch)
tree3bd50c189ed59ac7a0f1781c4c2aa1d2df188f6d
parentf366ac469f6a4a004286a9dccd5ddc3ea79c3690 (diff)
downloadaur-171e9f1e92e998302b7945dc1269c890f3c25e3a.tar.gz
Add check() and touch up
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef659aa92aef..04565659b246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
# Generated by mksrcinfo v8
-# Thu May 11 13:04:37 UTC 2017
+# Sun Jun 25 03:37:12 UTC 2017
pkgbase = python-icalendar
pkgdesc = A parser/generator of iCalendar files (RFC 2445)
pkgver = 3.11.4
pkgrel = 1
- url = http://pypi.python.org/pypi/icalendar/
+ url = https://github.com/collective/icalendar
arch = any
license = GPL
makedepends = python-setuptools
- depends = python
- depends = python-pytz
depends = python-dateutil
- conflicts = python-icalendar-git
- source = https://pypi.python.org/packages/bb/6a/486b4a882d03042e569a40a4e17aebcb1d8d2b8f54620007adaba43c67af/icalendar-3.11.4.tar.gz#md5=5e05eb70f484abf8e8a3ac3ec5af48df
- sha512sums = ac51717cced4f1730fa0e81ca5dec5f4deda04f3bb78d05c5e56b9e50b7f79f556a2c7d76fb7b50b8c6d5c2751a79b09a93230ff2e2c78df9106446b9f867f6e
+ depends = python-pytz
+ source = icalendar-3.11.4.tar.gz::https://github.com/collective/icalendar/archive/3.11.4.tar.gz
+ sha512sums = 577d26694bdb6d9c41ee1538ab3c3e2cc4d5c8a9e1b48d7f727f0fb4fe5c04f7f2c87d0d8afef2928a769ef252f256f05d03e3b910fab8778f63b3558d929444
pkgname = python-icalendar
diff --git a/PKGBUILD b/PKGBUILD
index f43f711ea89b..c3fe118eda8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Sirat18 <aur@sirat18.de>
+# Maintainer: Daniel M. Capella <polyzen@archlinux.info>
+# Contributor: Sirat18 <aur@sirat18.de>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=python-icalendar
@@ -6,18 +7,21 @@ pkgver=3.11.4
pkgrel=1
pkgdesc='A parser/generator of iCalendar files (RFC 2445)'
arch=('any')
-url='http://pypi.python.org/pypi/icalendar/'
+url=https://github.com/collective/icalendar
license=('GPL')
-depends=('python' 'python-pytz' 'python-dateutil')
+depends=('python-dateutil' 'python-pytz')
makedepends=('python-setuptools')
-conflicts=('python-icalendar-git')
+source=("icalendar-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('577d26694bdb6d9c41ee1538ab3c3e2cc4d5c8a9e1b48d7f727f0fb4fe5c04f7f2c87d0d8afef2928a769ef252f256f05d03e3b910fab8778f63b3558d929444')
-source=("https://pypi.python.org/packages/bb/6a/486b4a882d03042e569a40a4e17aebcb1d8d2b8f54620007adaba43c67af/icalendar-3.11.4.tar.gz#md5=5e05eb70f484abf8e8a3ac3ec5af48df")
-sha512sums=('ac51717cced4f1730fa0e81ca5dec5f4deda04f3bb78d05c5e56b9e50b7f79f556a2c7d76fb7b50b8c6d5c2751a79b09a93230ff2e2c78df9106446b9f867f6e')
+check() {
+ cd icalendar-$pkgver
+ python setup.py test
+}
package() {
- cd "icalendar-${pkgver}"
- python setup.py install --root=${pkgdir} --optimize=1
+ cd icalendar-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
}
# vim:set ts=2 sw=2 et: