summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFinn Steglich2015-06-18 14:07:06 +0200
committerFinn Steglich2015-06-18 14:07:06 +0200
commitdc9977a678a0f566c784804fd6947d9523f94797 (patch)
treec9485be7621ee4246990b5de61e2b0f133bb2bd0
downloadaur-dc9977a678a0f566c784804fd6947d9523f94797.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97cd8d2bedf9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-icalendar
+ pkgdesc = A parser/generator of iCalendar files (RFC 2445)
+ pkgver = 3.9.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/icalendar/
+ arch = any
+ license = GPL
+ makedepends = python-distribute
+ depends = python
+ depends = python-pytz
+ depends = python-dateutil
+ conflicts = python-icalendar-git
+ source = https://pypi.python.org/packages/source/i/icalendar/icalendar-3.9.0.tar.gz
+ sha512sums = a937882046666212d011cbd5963f43e3c2ebc677c55f1ac425dd77a08201a204498881986208d40e2e93b163f9f51b285cb3a1250f07d01f9b6a968c4e24065d
+
+pkgname = python-icalendar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..611e6a1eb65b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sirat18 <aur@sirat18.de>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=python-icalendar
+pkgver=3.9.0
+pkgrel=1
+pkgdesc='A parser/generator of iCalendar files (RFC 2445)'
+arch=('any')
+url='http://pypi.python.org/pypi/icalendar/'
+license=('GPL')
+depends=('python' 'python-pytz' 'python-dateutil')
+makedepends=('python-distribute')
+conflicts=('python-icalendar-git')
+
+source=("https://pypi.python.org/packages/source/i/icalendar/icalendar-${pkgver}.tar.gz")
+sha512sums=('a937882046666212d011cbd5963f43e3c2ebc677c55f1ac425dd77a08201a204498881986208d40e2e93b163f9f51b285cb3a1250f07d01f9b6a968c4e24065d')
+
+package() {
+ cd "icalendar-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: