aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Pasquier2017-02-19 21:53:19 +0100
committerVincent Pasquier2017-02-19 21:53:19 +0100
commit619e86ce009fda467f8afab020cb389617146285 (patch)
tree5bc138f49ae296f4807945720212407529d248ab
downloadaur-619e86ce009fda467f8afab020cb389617146285.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bde9a199b5d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-ics
+ pkgdesc = Pythonic and easy iCalendar library
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/ics/
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/e0/b6/6238912420684e3da7c81c13012e28df6f0c2c978c37e5c57838b9987cc7/ics-0.3.1.tar.gz
+ sha512sums = 3e08c51f81f333983beca7cfb77e072d55e68b333d59143173a3dad5a7e439476b53583563fb300b25c871d121c4a5cbed898b3073a80e4d4efb7f12010340e8
+
+pkgname = python-ics
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ce9ccf3b0fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Vincent Pasquier <vincentpasquier@posteo.net>
+
+pkgname_=ics
+pkgname=python-${pkgname_}
+pkgver=0.3.1
+pkgrel=1
+pkgdesc='Pythonic and easy iCalendar library'
+arch=('any')
+url='http://pypi.python.org/pypi/ics/'
+license=('Apache')
+depends=('python')
+makedepends=('python-setuptools')
+
+source=("https://pypi.python.org/packages/e0/b6/6238912420684e3da7c81c13012e28df6f0c2c978c37e5c57838b9987cc7/${pkgname_}-${pkgver}.tar.gz")
+sha512sums=('3e08c51f81f333983beca7cfb77e072d55e68b333d59143173a3dad5a7e439476b53583563fb300b25c871d121c4a5cbed898b3073a80e4d4efb7f12010340e8')
+
+package() {
+ cd "$pkgname_-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: