aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYngve Levinsen2020-01-03 09:41:45 +0100
committerYngve Levinsen2020-01-03 09:41:45 +0100
commitc64e7986f4d799496c5edf577c3e842099fe33e5 (patch)
treec1bdf793e87d8a69d1ffeca5aef89477f516e5f3
parentb47d0cc577c646c813754e87bd7ff7ad2b270dad (diff)
downloadaur-c64e7986f4d799496c5edf577c3e842099fe33e5.tar.gz
new version 0.6
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
-rw-r--r--README.md15
4 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3507e7bf21a2..92bad5f35cb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ics
pkgdesc = Pythonic and easy iCalendar library
- pkgver = 0.5
+ pkgver = 0.6
pkgrel = 1
url = http://pypi.python.org/pypi/ics/
arch = any
@@ -9,8 +9,9 @@ pkgbase = python-ics
depends = python
depends = python-arrow
depends = python-dateutil
- source = https://github.com/C4ptainCrunch/ics.py/archive/v0.5.tar.gz
- sha512sums = 27fc2660cb069d003e6053587a32c54895ff4e1878145274cf88142b36ec47e88b73b1c1835da2b0ebdd945fefd24ceceff8efda11905edaf94de9bd95bdb91a
+ depends = python-tatsu
+ source = python-ics-0.6.tar.gz::https://github.com/C4ptainCrunch/ics.py/archive/v0.6.tar.gz
+ sha512sums = a6b23bba9e47d52c22b789965ffb1fcc2ae2905afd2e50ffeff5f7f25e38dd75444a5aa30c90b60b74b596b7f71ad26bd0eb52893fc2bbb9f6e4b0241be936de
pkgname = python-ics
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 72e8ffc0db8a..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-*
diff --git a/PKGBUILD b/PKGBUILD
index 5935e069231a..2566181f4439 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: Vincent Pasquier <vincentpasquier@posteo.net>
pkgname=python-ics
-pkgver=0.5
+pkgver=0.6
pkgrel=1
pkgdesc='Pythonic and easy iCalendar library'
arch=('any')
url='http://pypi.python.org/pypi/ics/'
license=('Apache')
-depends=('python' 'python-arrow' 'python-dateutil')
+depends=('python' 'python-arrow' 'python-dateutil' 'python-tatsu')
makedepends=('python-setuptools')
-source=("https://github.com/C4ptainCrunch/ics.py/archive/v${pkgver}.tar.gz")
-sha512sums=('27fc2660cb069d003e6053587a32c54895ff4e1878145274cf88142b36ec47e88b73b1c1835da2b0ebdd945fefd24ceceff8efda11905edaf94de9bd95bdb91a')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/C4ptainCrunch/ics.py/archive/v${pkgver}.tar.gz")
+sha512sums=('a6b23bba9e47d52c22b789965ffb1fcc2ae2905afd2e50ffeff5f7f25e38dd75444a5aa30c90b60b74b596b7f71ad26bd0eb52893fc2bbb9f6e4b0241be936de')
package() {
cd "ics.py-${pkgver}"
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..297785e7c610
--- /dev/null
+++ b/README.md
@@ -0,0 +1,15 @@
+## Build
+
+```bash
+# Test PKGBUILD
+namcap PKGBUILD
+# Build
+makepkg
+# Test artifact
+namcap <package file name>.pkg.tar.xz
+# Install
+pacman -U <package file name>.pkg.tar.xz
+# Generate SRCINFO
+makepkg --printsrcinfo > .SRCINFO
+# Commit & Publish
+```