summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2015-08-10 20:24:08 +1000
committerMatthew Gamble2015-08-10 20:24:08 +1000
commit4ae59dd91fdd3ecd9640c82710323fd7b28430fb (patch)
tree359a8d6cc6d1ec522bb136d3bcd270a966903228
downloadaur-4ae59dd91fdd3ecd9640c82710323fd7b28430fb.tar.gz
Initial import from AUR3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cada5ed18090
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-idiotscript
+ pkgdesc = An easier, less powerful alternative to regular expressions
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/djmattyg007/IdiotScript
+ arch = any
+ license = UNLICENSE
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/djmattyg007/IdiotScript/archive/1.1.1.zip
+ sha256sums = c92ebfab3e3259eecafa0e3109b72fe7e713ab1dbae098175e72a923d439ae76
+
+pkgname = python-idiotscript
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b864b66fc009
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Matthew Gamble
+
+pkgname=python-idiotscript
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="An easier, less powerful alternative to regular expressions"
+arch=('any')
+url='https://github.com/djmattyg007/IdiotScript'
+license=('UNLICENSE')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/djmattyg007/IdiotScript/archive/$pkgver.zip")
+sha256sums=("c92ebfab3e3259eecafa0e3109b72fe7e713ab1dbae098175e72a923d439ae76")
+
+package() {
+ cd "IdiotScript-$pkgver"
+ python setup.py install --root="$pkgdir"
+}