summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHåvard Pettersson2018-04-02 14:49:07 +0200
committerHåvard Pettersson2018-04-02 14:49:07 +0200
commit2cde562f56cc7bfbfb1a172bd056f433d2742564 (patch)
tree450c028cf83b07288775706e35b789982e514475
parentae6d87eb1ded1f1e34f491fc289f11d54e8c7fea (diff)
downloadaur-python-iexfinance.tar.gz
v0.3.1, add missing deps
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ac68f0ab54e..1e87f23bc5e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-iexfinance
pkgdesc = Python wrapper for the Investor's Exchange (IEX) Developer API
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://addisonlynch.github.io/iexfinance/
arch = any
@@ -8,11 +8,15 @@ pkgbase = python-iexfinance
makedepends = python-setuptools
makedepends = python2-setuptools
depends = python
- source = python-iexfinance::git+https://github.com/addisonlynch/iexfinance.git#tag=v0.3.0
+ depends = python-pandas
+ depends = python-requests
+ source = python-iexfinance::git+https://github.com/addisonlynch/iexfinance.git#tag=v0.3.1
sha256sums = SKIP
pkgname = python-iexfinance
pkgname = python2-iexfinance
depends = python2
+ depends = python2-pandas
+ depends = python2-requests
diff --git a/PKGBUILD b/PKGBUILD
index 73f1466167ba..c3afa1791abb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgbase=python-iexfinance
pkgname=(python-iexfinance python2-iexfinance)
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="Python wrapper for the Investor's Exchange (IEX) Developer API"
url='https://addisonlynch.github.io/iexfinance/'
arch=(any)
license=(apache)
-depends=(python)
+depends=(python python-pandas python-requests)
makedepends=(python-setuptools python2-setuptools)
source=("${pkgbase}::git+https://github.com/addisonlynch/iexfinance.git#tag=v$pkgver")
sha256sums=(SKIP)
@@ -23,7 +23,7 @@ package_python-iexfinance() {
}
package_python2-iexfinance() {
- depends=(python2)
+ depends=(python2 python2-pandas python2-requests)
cd ${pkgbase}2
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1