summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHåvard Pettersson2018-04-02 14:44:57 +0200
committerHåvard Pettersson2018-04-02 14:44:57 +0200
commit6b7479815180d11f40d1a41627726e2620a16256 (patch)
treeb16e0991043d120bad79931fcded1c92cd29afb4
parentf7c7be9a0174aa4817f1837a20e2794622194e10 (diff)
downloadaur-6b7479815180d11f40d1a41627726e2620a16256.tar.gz
Fix missing dependencies
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5017d29d1e1..2cc0bf9c2483 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Jan 5 13:49:49 UTC 2018
pkgbase = python-iexfinance-git
pkgdesc = Python wrapper for the Investor's Exchange (IEX) Developer API
- pkgver = r11.d60cb4b
+ pkgver = r53.d6d7710
pkgrel = 1
url = https://addisonlynch.github.io/iexfinance/
arch = any
@@ -10,6 +8,8 @@ pkgbase = python-iexfinance-git
makedepends = python-setuptools
makedepends = python2-setuptools
depends = python
+ depends = python-pandas
+ depends = python-requests
conflicts = python-iexfinance
source = python-iexfinance-git::git+https://github.com/addisonlynch/iexfinance.git
sha256sums = SKIP
@@ -18,5 +18,7 @@ pkgname = python-iexfinance-git
pkgname = python2-iexfinance-git
depends = python2
+ depends = python2-pandas
+ depends = python2-requests
conflicts = python2-iexfinance
diff --git a/PKGBUILD b/PKGBUILD
index 3d9a82ef0e17..8b5cdfac3d10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgbase=python-iexfinance-git
pkgname=(python-iexfinance-git python2-iexfinance-git)
-pkgver=r11.d60cb4b
+pkgver=r53.d6d7710
pkgrel=1
pkgdesc="Python wrapper for the Investor's Exchange (IEX) Developer API"
url='https://addisonlynch.github.io/iexfinance/'
arch=(any)
license=(apache)
-depends=(python)
+depends=(python python-pandas python-requests)
makedepends=(python-setuptools python2-setuptools)
conflicts=(python-iexfinance)
source=("${pkgname[0]}::git+https://github.com/addisonlynch/iexfinance.git")
@@ -29,7 +29,7 @@ package_python-iexfinance-git() {
}
package_python2-iexfinance-git() {
- depends=(python2)
+ depends=(python2 python2-pandas python2-requests)
conflicts=(python2-iexfinance)
cd ${pkgname[1]}