summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-11-06 05:35:05 -0700
committerAinola2018-11-06 05:35:05 -0700
commit8da879bc0cf9df2952366f1aa9722acc107cc71d (patch)
treef2f8a540c205e6cf70179de032c9d21cd6e941f5
parentdd6ddd743cf1bb4932c2931d8fd46d88d8de8fec (diff)
downloadaur-8da879bc0cf9df2952366f1aa9722acc107cc71d.tar.gz
use a less dumb source
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a2db441fbe0..573f3103cb72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Sep 3 06:56:42 UTC 2018
pkgbase = python-image
pkgdesc = Django application that provides editing for images and videos.
pkgver = 1.5.24
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/francescortiz/image
arch = any
license = BSD
@@ -16,7 +14,7 @@ pkgbase = python-image
makedepends = python2-requests
makedepends = python2-django
optdepends = ffmpeg: For video thumbnails
- source = https://files.pythonhosted.org/packages/3a/44/2fd9ba8a27b289389de47d85f50de0fadeb409fe1c448f59d4ae7787dadb/image-1.5.24.tar.gz
+ source = python-image-1.5.24.tar.gz::https://files.pythonhosted.org/packages/source/i/image/image-1.5.24.tar.gz
sha256sums = cfe64396b45dd31ff0ea390c80d63728b1df5e311b7c4a907a42f1bdded85515
pkgname = python-image
diff --git a/PKGBUILD b/PKGBUILD
index 949f87dedff4..7ab06cd58571 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-image
pkgname=('python-image' 'python2-image')
pkgver=1.5.24
-pkgrel=1
+pkgrel=2
pkgdesc="Django application that provides editing for images and videos."
arch=('any')
url="https://github.com/francescortiz/image"
@@ -11,7 +11,7 @@ license=('BSD')
makedepends=('python-setuptools' 'python-pillow' 'python-requests' 'python-django'
'python2-setuptools' 'python2-pillow' 'python2-requests' 'python2-django')
optdepends=('ffmpeg: For video thumbnails')
-source=("https://files.pythonhosted.org/packages/3a/44/2fd9ba8a27b289389de47d85f50de0fadeb409fe1c448f59d4ae7787dadb/image-$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/i/image/image-$pkgver.tar.gz")
sha256sums=('cfe64396b45dd31ff0ea390c80d63728b1df5e311b7c4a907a42f1bdded85515')
prepare() {
@@ -26,7 +26,7 @@ build() {
package_python-image() {
depends=('python-pillow' 'python-requests' 'python-django')
- cd "$srcdir/image-$pkgver"
+ cd "image-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 README -t "$pkgdir/usr/share/licenses/$pkgname/"
@@ -35,7 +35,7 @@ package_python-image() {
package_python2-image() {
depends=('python2-pillow' 'python2-requests' 'python2-django')
- cd "$srcdir/image-$pkgver-py2"
+ cd "image-$pkgver-py2"
python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 README -t "$pkgdir/usr/share/licenses/$pkgname/"