summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorØystein Sture2023-09-12 14:32:34 +0200
committerØystein Sture2023-09-12 14:32:34 +0200
commitb0c0e33f58f5ad62f3292547c521290cc238867f (patch)
tree0028980501793fd608e40df1a15ce1b25af7ac66
parent3925b9d53cdfd599d4c1a7d1a78553a6f20a82fc (diff)
downloadaur-python-imageio-ffmpeg.tar.gz
v0.4.9
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--pip_requirement.patch12
3 files changed, 7 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ac41869245f..90ea12bdb2a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-imageio-ffmpeg
pkgdesc = FFMPEG wrapper for Python
- pkgver = 0.4.8
- pkgrel = 3
+ pkgver = 0.4.9
+ pkgrel = 1
url = https://github.com/imageio/imageio-ffmpeg
arch = any
license = BSD
@@ -12,9 +12,7 @@ pkgbase = python-imageio-ffmpeg
makedepends = python-setuptools
depends = python
depends = ffmpeg
- source = git+https://github.com/imageio/imageio-ffmpeg.git#tag=v0.4.8
- source = pip_requirement.patch
+ source = git+https://github.com/imageio/imageio-ffmpeg.git#tag=v0.4.9
sha256sums = SKIP
- sha256sums = 16d32a6e263fa30ae43c7d050d5a3d657ab1222fccd4f4d603c797317ccb57ae
pkgname = python-imageio-ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index dac3509d8a65..70301e8dbdae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,16 @@
# Contributor:
pkgname=python-imageio-ffmpeg
-pkgver=0.4.8
-pkgrel=3
+pkgver=0.4.9
+pkgrel=1
pkgdesc="FFMPEG wrapper for Python"
arch=("any")
license=("BSD")
url="https://github.com/imageio/imageio-ffmpeg"
depends=('python' 'ffmpeg')
makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
-source=("git+https://github.com/imageio/imageio-ffmpeg.git#tag=v${pkgver}"
- "pip_requirement.patch")
-sha256sums=('SKIP'
- '16d32a6e263fa30ae43c7d050d5a3d657ab1222fccd4f4d603c797317ccb57ae')
-
-prepare() {
- cd "imageio-ffmpeg"
- patch --forward --strip=1 --input="${srcdir}/pip_requirement.patch"
-}
+source=("git+https://github.com/imageio/imageio-ffmpeg.git#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
cd "imageio-ffmpeg"
diff --git a/pip_requirement.patch b/pip_requirement.patch
deleted file mode 100644
index 80bbd147464b..000000000000
--- a/pip_requirement.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text imageio-ffmpeg-0.4.6.orig/setup.py imageio-ffmpeg-0.4.6.new/setup.py
---- imageio-ffmpeg-0.4.6.orig/setup.py 2022-04-13 00:00:00.000000000 +0000
-+++ imageio-ffmpeg-0.4.6.new/setup.py 2022-04-14 00:00:00.000000000 +0000
-@@ -57,7 +57,7 @@
- platforms="any",
- provides=["imageio_ffmpeg"],
- python_requires=">=3.5",
-- setup_requires=["pip>19"],
-+ setup_requires=[],
- install_requires=[],
- packages=["imageio_ffmpeg"],
- package_dir={"imageio_ffmpeg": "imageio_ffmpeg"},