summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPi-Yueh Chuang2021-04-30 15:48:22 -0400
committerPi-Yueh Chuang2021-04-30 15:48:22 -0400
commit68e5d370990b8e14a64c5b2612f4eeb871849e1c (patch)
tree1342ad943c850c8f638c8c2684d426d52dcfc93d
parent6341ef65ef880c930fe1f658449f0d90348077db (diff)
downloadaur-68e5d370990b8e14a64c5b2612f4eeb871849e1c.tar.gz
upgpkg: python-imaplib2 3.06-1
- update to Python 3 - fix commit to v3.06
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae66fff34ddc..ad0f4d2132c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-imaplib2
- pkgdesc = Python IMAP4rev1 mail protocol client class using threads for parallel operation
- pkgver = 2.57
+ pkgdesc = Threaded Python IMAP4 client
+ pkgver = 3.06
pkgrel = 1
- url = https://github.com/imaplib2/imaplib2
+ url = https://github.com/jazzband/imaplib2
arch = any
license = Python
makedepends = git
- makedepends = python2-setuptools
- depends = python2
- source = git+https://github.com/imaplib2/imaplib2.git#commit=3e87a66750b4fe79ffafdb1cce8509801720d125
+ makedepends = python-setuptools
+ depends = python
+ provides = python-imaplib2
+ conflicts = python-imaplib2-git
+ source = python-imaplib2::git+https://github.com/jazzband/imaplib2.git#commit=be2c018ddcd0d2d756147558ac0da91d25f1c9c7
md5sums = SKIP
pkgname = python-imaplib2
diff --git a/PKGBUILD b/PKGBUILD
index c9edd76d951a..03d6fa578399 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
+# Maintainer: Pi-Yueh Chuang <pychuang@pm.me>
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
-
pkgname=python-imaplib2
-_pkgname=imaplib2
-pkgver=2.57
-_pkgcommit=3e87a66750b4fe79ffafdb1cce8509801720d125
+pkgver=3.06
pkgrel=1
-pkgdesc="Python IMAP4rev1 mail protocol client class using threads for parallel operation"
+pkgdesc="Threaded Python IMAP4 client"
arch=('any')
-url="https://github.com/imaplib2/imaplib2"
+url="https://github.com/jazzband/imaplib2"
license=('Python')
-depends=('python2')
-makedepends=('git' 'python2-setuptools')
-source=(git+https://github.com/${_pkgname}/${_pkgname}.git#commit=${_pkgcommit})
+depends=('python')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("${pkgname}::git+https://github.com/jazzband/imaplib2.git#commit=be2c018ddcd0d2d756147558ac0da91d25f1c9c7")
md5sums=('SKIP')
-
build() {
- cd "$_pkgname"
- python2 setup.py build
+ cd "${pkgname}"
+ python setup.py build
}
package() {
- cd "$_pkgname"
- python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "${pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # install README
+ install -Dm644 "README" -t "$pkgdir/usr/share/doc/$pkgname"
}