summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2016-10-07 20:41:29 +1100
committerRhinoceros2016-10-07 20:41:29 +1100
commit8f05f43ebf70d43aa7510ff01e99d4817ce5e22d (patch)
tree83da15dc2ca0d1f84c52448883c49255f72fef32
downloadaur-8f05f43ebf70d43aa7510ff01e99d4817ce5e22d.tar.gz
Initial commit of 0.0.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a78136220e19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Oct 7 09:37:31 UTC 2016
+pkgbase = python-imapnotify
+ pkgdesc = Execute scripts on new messages using IDLE imap command (python version)
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/a-sk/python-imapnotify
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python>=3.5
+ depends = python-pytest-runner>=2.0
+ depends = python-pytest-runner<3
+ depends = python-aioimaplib>=0.5.14
+ depends = python-aioimaplib<1.0.0
+ source = https://github.com/a-sk/python-imapnotify/archive/0.0.1.tar.gz
+ md5sums = 9c99d997667cc8c35acbbe5f3a95d5a9
+
+pkgname = python-imapnotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..876dd21e36e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=python-imapnotify
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Execute scripts on new messages using IDLE imap command (python version)'
+arch=('any')
+url='https://github.com/a-sk/python-imapnotify'
+license=('custom')
+depends=('python>=3.5' 'python-pytest-runner>=2.0' 'python-pytest-runner<3' 'python-aioimaplib>=0.5.14' 'python-aioimaplib<1.0.0')
+makedepends=('python-setuptools')
+source=("https://github.com/a-sk/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('9c99d997667cc8c35acbbe5f3a95d5a9')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}