summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordianlujitao2018-09-01 21:11:02 +0800
committerdianlujitao2018-09-01 21:11:02 +0800
commitcb738d93a06565f719b519dbd398597bb8efcfee (patch)
tree7679180f513fbd4327ab9762e8ffac9b6ad58881
downloadaur-cb738d93a06565f719b519dbd398597bb8efcfee.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5dbbdb45fc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-imgaug
+ pkgdesc = Image augmentation for machine learning experiments
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://github.com/aleju/imgaug
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-scikit-image
+ source = imgaug-0.2.6.tar.gz::https://github.com/aleju/imgaug/archive/0.2.6.tar.gz
+ sha256sums = 79ea496780bfb2d7390759bb578c2a8444bfc09188b28b5c0e4bc74b7f14b9c7
+
+pkgname = python-imgaug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc95ab383376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: dianlujitao <dianlujitao at gmail dot com>
+
+pkgname=python-imgaug
+pkgver=0.2.6
+pkgrel=1
+pkgdesc="Image augmentation for machine learning experiments"
+url="https://github.com/aleju/imgaug"
+depends=('python' 'python-six' 'python-numpy' 'python-scipy' 'python-scikit-image')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("imgaug-$pkgver.tar.gz::https://github.com/aleju/imgaug/archive/$pkgver.tar.gz")
+sha256sums=('79ea496780bfb2d7390759bb578c2a8444bfc09188b28b5c0e4bc74b7f14b9c7')
+
+build() {
+ cd $srcdir/imgaug-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/imgaug-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}