summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2020-08-04 17:07:37 +0800
committerButui Hu2020-08-04 17:07:37 +0800
commit365e49864669d96694771f75d2fcab628692323c (patch)
tree96438f5bc2e90b339af60dbfe4049a3744c9a785
downloadaur-365e49864669d96694771f75d2fcab628692323c.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b34706b03feb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-imgviz
+ pkgdesc = Image Visualization Tools (object detection, semantic and instance segmentation)
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/wkentaro/imgviz
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = python-pillow
+ depends = python-yaml
+ source = python-imgviz-1.2.2.tar.gz::https://github.com/wkentaro/imgviz/archive/v1.2.2.tar.gz
+ sha512sums = e8e43e6674232902f77ac7d6f23632ade3e791535796cc60bfeaa0815b77b0c80819014d76f02431dc91f4368e8c3a066b4a3449eb6412c25c6dce185e25e47b
+
+pkgname = python-imgviz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3b6945decf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+_pkgname=imgviz
+pkgname=python-imgviz
+pkgver=1.2.2
+pkgrel=1
+pkgdesc='Image Visualization Tools (object detection, semantic and instance segmentation)'
+arch=('any')
+url='https://github.com/wkentaro/imgviz'
+license=('MIT')
+depends=(
+ python-matplotlib
+ python-numpy
+ python-pillow
+ python-yaml
+)
+makedepends=(
+ python-setuptools
+)
+checkdepends=(
+ python-pytest
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wkentaro/imgviz/archive/v${pkgver}.tar.gz")
+sha512sums=('e8e43e6674232902f77ac7d6f23632ade3e791535796cc60bfeaa0815b77b0c80819014d76f02431dc91f4368e8c3a066b4a3449eb6412c25c6dce185e25e47b')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "${_pkgname}-${pkgver}"
+ PYTHONPATH="${PWD}/build/lib" pytest -v
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: