summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-01-27 16:15:08 +0800
committerUniversebenzene2019-01-27 16:15:08 +0800
commit054fa1b2336118c8eb09eea82737279a3927e241 (patch)
treede8dc098e88d2214f589d48860b1600d8dc7666b
parentfd8acc50cd8ef0287b403846a0bf23feec21d75b (diff)
downloadaur-054fa1b2336118c8eb09eea82737279a3927e241.tar.gz
Add python2 version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD54
2 files changed, 38 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fdb7de1529e..3e7958a78248 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 27 06:20:12 UTC 2019
+# Sun Jan 27 08:13:36 UTC 2019
pkgbase = python-iminuit
pkgdesc = Python interface for MINUIT, a physics analysis tool for function minimization.
pkgver = 1.3.3
@@ -12,7 +12,9 @@ pkgbase = python-iminuit
checkdepends = python-pytest
checkdepends = jupyter-nbconvert
makedepends = cython
+ makedepends = cython2
makedepends = python-numpy
+ makedepends = python2-numpy
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/i/iminuit/iminuit-1.3.3.tar.gz
md5sums = 35f074f44dadd4e20dd110576c8a0ffc
@@ -27,3 +29,13 @@ pkgname = python-iminuit
optdepends = python-sphinx: For docs building
optdepends = python-iminuit-doc: Documentation for python-iminuit
+pkgname = python2-iminuit
+ depends = python2>=2.7
+ depends = python2-numpy
+ optdepends = ipython2
+ optdepends = python2-matplotlib
+ optdepends = python2-pytest-cov: For testing and get a coverage report
+ optdepends = cython2
+ optdepends = python2-sphinx: For docs building
+ optdepends = python-iminuit-doc: Documentation for python-iminuit
+
diff --git a/PKGBUILD b/PKGBUILD
index 050460c6773f..b22aa30c1733 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,31 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-iminuit
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}")
-#"python2-${_pyname}")
+pkgname=("python-${_pyname}" "python2-${_pyname}")
pkgver=1.3.3
pkgrel=1
pkgdesc="Python interface for MINUIT, a physics analysis tool for function minimization."
arch=('i686' 'x86_64')
url="http://iminuit.readthedocs.io/"
license=('GPL' 'MIT')
-makedepends=('cython'
-# 'cython2'
-# 'python2-numpy'
- 'python-numpy')
+makedepends=('cython' 'cython2' 'python-numpy' 'python2-numpy')
checkdepends=('python-pytest' 'jupyter-nbconvert')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
md5sums=('35f074f44dadd4e20dd110576c8a0ffc')
-#prepare() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
-#}
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
+}
build() {
-# msg "Building Python2"
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py build
+ msg "Building Python2"
+ cd ${srcdir}/${_pyname}-${pkgver}-py2
+ python2 setup.py build
-# msg "Building Python3"
+ msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
}
@@ -42,20 +38,20 @@ check() {
# python2 setup.py test
}
-#package_python2-iminuit() {
-# depends=('python2>=2.7' 'python2-numpy')
-# optdepends=('ipython2'
-# 'python2-matplotlib'
-# 'python2-pytest-cov: For testing and get a coverage report'
-# 'cython2'
-# 'python2-sphinx: For docs building'
-# 'python-iminuit-doc: Documentation for python-iminuit')
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-#
-# install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
-# install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
-# python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
-#}
+package_python2-iminuit() {
+ depends=('python2>=2.7' 'python2-numpy')
+ optdepends=('ipython2'
+ 'python2-matplotlib'
+ 'python2-pytest-cov: For testing and get a coverage report'
+ 'cython2'
+ 'python2-sphinx: For docs building'
+ 'python-iminuit-doc: Documentation for python-iminuit')
+ cd ${srcdir}/${_pyname}-${pkgver}-py2
+
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
package_python-iminuit() {
depends=('python>=3.4' 'python-numpy')