summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-12-19 19:14:10 +0800
committerUniversebenzene2020-12-19 19:14:10 +0800
commit51de70fd3a9b685bfdaabe90064374f135d8afab (patch)
treeb3d2a7c491b9c7ea4fa0384eeb794e864ed600f3
parent5c3d64fc496c1176a6b299f6697a78534c34331e (diff)
downloadaur-51de70fd3a9b685bfdaabe90064374f135d8afab.tar.gz
Update to version 2.1.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0a06827cace..32414aab6733 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = python-iminuit
pkgdesc = Python interface for MINUIT, a physics analysis tool for function minimization.
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = http://iminuit.readthedocs.io
arch = i686
arch = x86_64
license = GPL
license = MIT
- checkdepends = python-pytest
makedepends = python-setuptools
makedepends = python-numpy
makedepends = cmake
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/i/iminuit/iminuit-2.0.0.tar.gz
- md5sums = 42f28d997784b7f85e3cdda03041e5cf
+ source = https://files.pythonhosted.org/packages/source/i/iminuit/iminuit-2.1.0.tar.gz
+ md5sums = 247246f939db7cc532454e3bd909daf6
pkgname = python-iminuit
depends = python>=3.6
diff --git a/PKGBUILD b/PKGBUILD
index 8c85660c2942..3761c2a82afe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgbase=python-iminuit
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="Python interface for MINUIT, a physics analysis tool for function minimization."
arch=('i686' 'x86_64')
url="http://iminuit.readthedocs.io"
license=('GPL' 'MIT')
makedepends=('python-setuptools' 'python-numpy' 'cmake')
-checkdepends=('python-pytest')
+#checkdepends=('python-pytest')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('42f28d997784b7f85e3cdda03041e5cf')
+md5sums=('247246f939db7cc532454e3bd909daf6')
prepare() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
@@ -24,10 +24,10 @@ build() {
python setup.py build
}
-check() {
- cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
- pytest || warning "Tests failed"
-}
+#check() {
+# cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
+# pytest || warning "Tests failed"
+#}
package_python-iminuit() {
depends=('python>=3.6' 'python-numpy')