summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-12-09 13:35:04 +0800
committerUniversebenzene2020-12-09 13:35:04 +0800
commit5c3d64fc496c1176a6b299f6697a78534c34331e (patch)
treea3fd47da78605c6a9953a8fe6bf60e2d7daa411c
parentcdb7585e17a84883b3335dbdf6963da424b4020a (diff)
downloadaur-5c3d64fc496c1176a6b299f6697a78534c34331e.tar.gz
Update to version 2.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82f96162c179..d0a06827cace 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-iminuit
pkgdesc = Python interface for MINUIT, a physics analysis tool for function minimization.
- pkgver = 1.5.4
+ pkgver = 2.0.0
pkgrel = 1
url = http://iminuit.readthedocs.io
arch = i686
@@ -8,15 +8,16 @@ pkgbase = python-iminuit
license = GPL
license = MIT
checkdepends = python-pytest
- makedepends = cython
+ makedepends = python-setuptools
makedepends = python-numpy
+ makedepends = cmake
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/i/iminuit/iminuit-1.5.4.tar.gz
- md5sums = 9090d7599c2d8404aa2fb5b6ec1fad41
+ source = https://files.pythonhosted.org/packages/source/i/iminuit/iminuit-2.0.0.tar.gz
+ md5sums = 42f28d997784b7f85e3cdda03041e5cf
pkgname = python-iminuit
- depends = python>=3.5
- depends = python-numpy>=1.11.3
+ depends = python>=3.6
+ depends = python-numpy
optdepends = ipython
optdepends = python-matplotlib
optdepends = python-pytest-cov: For testing and get a coverage report
diff --git a/PKGBUILD b/PKGBUILD
index bf522b113b92..8c85660c2942 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgbase=python-iminuit
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=1.5.4
+pkgver=2.0.0
pkgrel=1
pkgdesc="Python interface for MINUIT, a physics analysis tool for function minimization."
arch=('i686' 'x86_64')
url="http://iminuit.readthedocs.io"
license=('GPL' 'MIT')
-makedepends=('cython' 'python-numpy')
+makedepends=('python-setuptools' 'python-numpy' 'cmake')
checkdepends=('python-pytest')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('9090d7599c2d8404aa2fb5b6ec1fad41')
+md5sums=('42f28d997784b7f85e3cdda03041e5cf')
prepare() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
@@ -30,7 +30,7 @@ check() {
}
package_python-iminuit() {
- depends=('python>=3.5' 'python-numpy>=1.11.3')
+ depends=('python>=3.6' 'python-numpy')
optdepends=('ipython'
'python-matplotlib'
'python-pytest-cov: For testing and get a coverage report'