summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-06-13 10:03:36 +0800
committerUniversebenzene2020-06-13 10:03:36 +0800
commit8a1eb27231f53c4ce7d51a8c0e791c603d2aead1 (patch)
tree1b5d1da53b5b2835e4d8cc5b0923f4a7e69daf81
parente96da5706b60c7d85d5f7db9025bbcf8eb3904aa (diff)
downloadaur-8a1eb27231f53c4ce7d51a8c0e791c603d2aead1.tar.gz
Update to version 1.4.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD48
2 files changed, 16 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c52fb31e85d..c380b657c4fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = python-iminuit
pkgdesc = Python interface for MINUIT, a physics analysis tool for function minimization.
- pkgver = 1.3.10
+ pkgver = 1.4.0
pkgrel = 1
- url = http://iminuit.readthedocs.io/
+ url = http://iminuit.readthedocs.io
arch = i686
arch = x86_64
license = GPL
license = MIT
+ checkdepends = python-pytest
makedepends = cython
- makedepends = cython2
makedepends = python-numpy
- makedepends = python2-numpy
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/i/iminuit/iminuit-1.3.10.tar.gz
- md5sums = 3ac6ae34905409acdd053e5551b3c95d
+ source = https://files.pythonhosted.org/packages/source/i/iminuit/iminuit-1.4.0.tar.gz
+ md5sums = 693cc4846e4afee7d5ad2ecc5f92e389
pkgname = python-iminuit
depends = python>=3.5
@@ -25,13 +24,3 @@ pkgname = python-iminuit
optdepends = python-sphinx: For docs building
optdepends = python-iminuit-doc: Documentation for python-iminuit
-pkgname = python2-iminuit
- depends = python2>=2.7
- depends = python2-numpy>=1.11.3
- optdepends = ipython2
- optdepends = python2-matplotlib
- optdepends = python2-pytest-cov: For testing and get a coverage report
- optdepends = cython2
- optdepends = python2-sphinx: For docs building
- optdepends = python-iminuit-doc: Documentation for python-iminuit
-
diff --git a/PKGBUILD b/PKGBUILD
index de3c7187a707..f80f075a0bcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,32 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-iminuit
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python2-${_pyname}")
-pkgver=1.3.10
+pkgname=("python-${_pyname}")
+pkgver=1.4.0
pkgrel=1
pkgdesc="Python interface for MINUIT, a physics analysis tool for function minimization."
arch=('i686' 'x86_64')
-url="http://iminuit.readthedocs.io/"
+url="http://iminuit.readthedocs.io"
license=('GPL' 'MIT')
-makedepends=('cython' 'cython2' 'python-numpy' 'python2-numpy')
-#checkdepends=('python-pytest-runner')
-#'jupyter-nbconvert')
+makedepends=('cython' 'python-numpy')
+checkdepends=('python-pytest')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('3ac6ae34905409acdd053e5551b3c95d')
+md5sums=('693cc4846e4afee7d5ad2ecc5f92e389')
prepare() {
- cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
-# export _pyver=$(python -V | cut -c 8-10)
+ export _pyver=$(python -V | cut -c 8-10)
}
build() {
- msg "Building Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py build
-
- msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
+
python setup.py build
}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-# python setup.py test
-# cd "./build/lib.linux-x86_64-${_pyver}"
-# pytest
-
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py test
-#}
-
-package_python2-iminuit() {
- depends=('python2>=2.7' 'python2-numpy>=1.11.3')
- optdepends=('ipython2'
- 'python2-matplotlib'
- 'python2-pytest-cov: For testing and get a coverage report'
- 'cython2'
- 'python2-sphinx: For docs building'
- 'python-iminuit-doc: Documentation for python-iminuit')
- cd ${srcdir}/${_pyname}-${pkgver}-py2
-
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
+ pytest || warning "Tests failed"
}
package_python-iminuit() {