summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrumeet2021-03-24 16:26:28 -0700
committerTrumeet2021-03-24 16:26:28 -0700
commit1549b08eeb795a81a4a2715b7adee7b97ce51bb1 (patch)
tree942b61d9077d28d2257ee65a710a8eccdd09e9c5
downloadaur-1549b08eeb795a81a4a2715b7adee7b97ce51bb1.tar.gz
First Commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD47
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff4c5e85b10a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-immutables
+ pkgdesc = A high-performance immutable mapping type for Python
+ pkgver = 0.15
+ pkgrel = 1
+ url = https://github.com/MagicStack/immutables
+ arch = x86_64
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/i/immutables/immutables-0.15.tar.gz
+ md5sums = 64628c8d813a4b3e954ef2af531eddc6
+
+pkgname = python-immutables
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3c52670f2ca2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.zst
+*.tar.gz
+*.log
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7f0ab0a3177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Yuuta Liang <yuuta@yuuta.moe>
+pkgname=python-immutables
+pkgver=0.15
+pkgrel=1
+epoch=
+pkgdesc="A high-performance immutable mapping type for Python"
+arch=(x86_64)
+url="https://github.com/MagicStack/immutables"
+license=('custom')
+groups=()
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+_name=${pkgname#python-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+noextract=()
+md5sums=('64628c8d813a4b3e954ef2af531eddc6')
+validpgpkeys=()
+
+prepare() {
+ cd "$_name-$pkgver"
+}
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$_name-$pkgver"
+ python -m unittest -v
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ mkdir -p $pkgdir/usr/share/licenses/${pkgname}/
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/
+}