summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-11-13 13:10:23 -0500
committerCarlos Aznarán2023-11-13 13:10:23 -0500
commit089f1039bbe521b71433b7460d83e5595c2a4e4e (patch)
tree7ff4bfe305b7bd3f43558cd793d59e4263cf1b69
parenta0e2477a1b3303ff6bd836bf782cf7f5eb227ea4 (diff)
downloadaur-089f1039bbe521b71433b7460d83e5595c2a4e4e.tar.gz
Follow Python guidelines
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c242b545dbd2..fd509d0fdbdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = python-imread
pkgdesc = Read images to numpy arrays
pkgver = 0.7.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/luispedro/imread
arch = x86_64
license = MIT
- checkdepends = python-nose
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
makedepends = libpng
makedepends = libjpeg-turbo
makedepends = libtiff
@@ -14,6 +16,8 @@ pkgbase = python-imread
makedepends = xcftools
depends = python-numpy
source = imread-0.7.4.tar.gz::https://github.com/luispedro/imread/archive/v0.7.4.tar.gz
+ source = atributeerror.patch::https://github.com/luispedro/imread/pull/44.patch
sha512sums = 6ec445ede6a25f57f2ab6ab3b4a89b91015edc6a73cb03124c746a21c4fcb1486abb88cf8d9980347afb4ed6b916bfd450b003ded1dc21aa1732c84472a90d28
+ sha512sums = ea17959e1f481682bbd06ed40cd0f41d4b6ab3e1bcfadcc49b348f7923da620a1580e3f1b90a08a257a2cbd1b9f3b36971c547a9218b0f266bbc53f205ee6190
pkgname = python-imread
diff --git a/PKGBUILD b/PKGBUILD
index ac599ecd10ed..e64a3e3e95ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,28 +6,29 @@ _base=imread
pkgname=python-${_base}
pkgdesc="Read images to numpy arrays"
pkgver=0.7.4
-pkgrel=2
+pkgrel=3
arch=(x86_64)
url="https://github.com/luispedro/${_base}"
license=(MIT)
depends=(python-numpy)
-makedepends=(python-setuptools libpng libjpeg-turbo libtiff libwebp xcftools)
-checkdepends=(python-nose)
-source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('6ec445ede6a25f57f2ab6ab3b4a89b91015edc6a73cb03124c746a21c4fcb1486abb88cf8d9980347afb4ed6b916bfd450b003ded1dc21aa1732c84472a90d28')
+makedepends=(python-build python-installer python-setuptools python-wheel libpng libjpeg-turbo libtiff libwebp xcftools)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
+ atributeerror.patch::${url}/pull/44.patch)
+sha512sums=('6ec445ede6a25f57f2ab6ab3b4a89b91015edc6a73cb03124c746a21c4fcb1486abb88cf8d9980347afb4ed6b916bfd450b003ded1dc21aa1732c84472a90d28'
+ 'ea17959e1f481682bbd06ed40cd0f41d4b6ab3e1bcfadcc49b348f7923da620a1580e3f1b90a08a257a2cbd1b9f3b36971c547a9218b0f266bbc53f205ee6190')
-build() {
+prepare() {
cd ${_base}-${pkgver}
- python setup.py build
+ patch -p1 -i ../atributeerror.patch
}
-check() {
+build() {
cd ${_base}-${pkgver}
- python setup.py test
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 COPYING.MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
}